summaryrefslogtreecommitdiff
path: root/app-editors/pluma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /app-editors/pluma
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'app-editors/pluma')
-rw-r--r--app-editors/pluma/Manifest2
-rw-r--r--app-editors/pluma/pluma-1.24.1.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index 1c6d3e6fa9b5..912b4205f7cc 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,3 +1,5 @@
DIST pluma-1.24.0.tar.xz 3717544 BLAKE2B fd9375fd05566c11c24d5bdf55ab0d4619143127a5e48c4e91d18421f50340775d58c3e2264382aa3bbd8aad0569c559e87381a9ece07ce1592d1bc1a5315db1 SHA512 390bf2949549baa0e3dc706526217fbc1513e2f9778917710da806e58cdfb0b7a36e95ed2186442490996cf76783acd4e0f4b8f1fedacee9ba356c0d466510be
+DIST pluma-1.24.1.tar.xz 3679636 BLAKE2B e792433b93862c8b0c47145255311c3a3386c1b99ec1ac87ed91608d839ece4430205f83fcc3c0f5145f986105d4c5d8803393035fcaaea08155197bbcf15d03 SHA512 0cfd6a035fc95993dce3e556c49641e799888f20159b29f2c0712c54ee772aa6df1ce755f329414c94efdb2cb3819ce633b92e6559b0c8cb064dab3c74729ab3
EBUILD pluma-1.24.0.ebuild 1780 BLAKE2B d845bbd202c228b0b8f11c1a74b6791081fabe9fdfe80e08e4e62b40e3e3e27b626caa9263f906b7c4eb9ad056412b0f18305a4a107d85ec14d7a39149d73e77 SHA512 1f81f212c6ad19b923e4f8a8aa5b935bb4ca05bba3059553583ecb178bc65bc562e939f690033d62e4737ba76e0d5b008076649dbabb06e87f632120fdfaabe2
+EBUILD pluma-1.24.1.ebuild 1786 BLAKE2B b857ee4a4f1d10b7867958238bcd8cf96cd1ad8cb2f710b9da51c01f1d175bc8dd98c41d82b05fc417f4af7fef597abfba30df96dd123358b08f8ef1c6e21b2f SHA512 96e61cac21d4f94b3efbea4c502e86a3b7c408b54bc79559acfdf599f4eebf6793413df33cf036770593c8bdf5a5390b5ae5bf8220c4cab8a9bd1e1e2d5fc39d
MISC metadata.xml 334 BLAKE2B 2d5ac79ba6879f5486724c826a89ed81cf393bc3fedbdea40764b1fb23962672e7c2a625137080a16ccd8e67a55097a4f497269f89ccd8b256490ef99e15b9cb SHA512 fe30c9986ed7086a894a0835847351d92938c424af5b7da51211a23fc197eebbce53cc205014cdd2c3bcc951a5a449c5d5726bede7991716d81fb7bbfe8a3fca
diff --git a/app-editors/pluma/pluma-1.24.1.ebuild b/app-editors/pluma/pluma-1.24.1.ebuild
new file mode 100644
index 000000000000..9d5382fbcd64
--- /dev/null
+++ b/app-editors/pluma/pluma-1.24.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit mate python-single-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection spell test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+ !!app-editors/mate-text-editor
+"
+
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}