summaryrefslogtreecommitdiff
path: root/app-editors/pluma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
commitd6260e76da0a436affc6839e470dd8619841cadc (patch)
treeca1df2a7c2e422ab51b16244374ae8ba94ab784e /app-editors/pluma
parent6990d0600970cefe6aa2c17668f9028b08d23441 (diff)
gentoo auto-resync : 11:04:2023 - 05:38:21
Diffstat (limited to 'app-editors/pluma')
-rw-r--r--app-editors/pluma/Manifest2
-rw-r--r--app-editors/pluma/files/pluma-1.26.0-fortify-source-3.patch24
-rw-r--r--app-editors/pluma/pluma-1.26.0-r1.ebuild83
3 files changed, 109 insertions, 0 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index 653861cce1bc..db80cafa03ee 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,3 +1,5 @@
+AUX pluma-1.26.0-fortify-source-3.patch 998 BLAKE2B 84536f238237d929e6af4362be3ee6c95329170efa2e862b93fce96ef7dd689732e2e4df4b533745254ebde7504b65b0b55c2cdcd817186738f67de889eeb5d3 SHA512 c5e4a56ecebaeb0bf58fc62daac0f4a0dd685ac758648672d1ed13c2abf51453e219aa0ce3c52e04386a80491fb4f43ed042ac32086f6eb6d73553e79ccf0575
DIST pluma-1.26.0.tar.xz 3765056 BLAKE2B 4a3107df7c4ba906d405b5ef3ea6dd9ca0e372a7b00224213fc8a60d1dc26663d1363aa7f0569b0242407f5b5d850386308fae9192c4a33f577295bb55ef5a16 SHA512 a6c0cee7110f4863e44af51b19bb528f0f3570eab8db98038152bf142eedde97ac13b896deff7051b941a0f43c6fe14e316a97eba40fe5d4854d76038450245f
+EBUILD pluma-1.26.0-r1.ebuild 1914 BLAKE2B 5230ac7e8d86f76f9ccf0616fcf6d59e52e0e9f4f47304eed596a67b9eea6d2dc6afd2ba458a3ba60999c2416b5e1ef9fbfdbdc7c07ceb636b324b5318e45293 SHA512 91807044d14920a7c004ee394eaea1c6382a2e0c3b481b4d1bce2a3bbf64e1cdffbbd4a73463dd38992e03300a7f6d8fe9bf33a17dfdd7692f8f92151fb41041
EBUILD pluma-1.26.0.ebuild 1856 BLAKE2B 995a4c5efae64e6fc0a9649849ffac2ecb513733415d6e24e7d09d710e8b869ead1540efe6a756a790dbe10072c04a7126355179ea5bbd2e1638f7245005c4ac SHA512 567342b27a07a8568df6e037a476fc45d8fc8ef04de6e701f2f8f41bf4b14cd2e2bb80984146150f19e228c596c029c1e12aa7674339fa02f2874c44bb111b7a
MISC metadata.xml 335 BLAKE2B 5a43dc64c90fc154ee0cb55c1eba79a20c612836229ee87e1594436db64d3ba5d877897ecfe4e2e1b52b75a8a3c336fe5338b203e9d134d14b531de4ca2c3eb5 SHA512 8a113126ce89a38ce4ec7468a7c45b162572ceb034911624ed9c5227dae4dedf33ffdfae0ace99ed18848b1e30b722e05b0715fe845b4ad0b6998e4d87476548
diff --git a/app-editors/pluma/files/pluma-1.26.0-fortify-source-3.patch b/app-editors/pluma/files/pluma-1.26.0-fortify-source-3.patch
new file mode 100644
index 000000000000..001d88081ce6
--- /dev/null
+++ b/app-editors/pluma/files/pluma-1.26.0-fortify-source-3.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/903860
+https://github.com/mate-desktop/pluma/issues/664
+https://github.com/mate-desktop/pluma/pull/665
+https://github.com/mate-desktop/pluma/commit/8ca37beb259f7a62fef2005e888248ec880e44cd
+
+From 8ca37beb259f7a62fef2005e888248ec880e44cd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bal=C3=A1zs=20Dura-Kov=C3=A1cs?= <balping314@gmail.com>
+Date: Thu, 18 Aug 2022 17:44:41 +0200
+Subject: [PATCH] Fix out-of-bounds write
+
+Closes https://github.com/mate-desktop/pluma/issues/664
+
+The size of tempfont was one byte too short, so strcpy performed an out-of-bounds write of the terminating 0.
+--- a/pluma/pluma-window.c
++++ b/pluma/pluma-window.c
+@@ -318,7 +318,7 @@ pluma_window_key_press_event (GtkWidget *widget,
+ g_strcanon (tempsize, "1234567890", '\0');
+ g_strreverse (tempsize);
+
+- gchar tempfont [strlen (font)];
++ gchar tempfont [strlen (font) + 1];
+ strcpy (tempfont, font);
+ tempfont [strlen (font) - strlen (tempsize)] = 0;
+
diff --git a/app-editors/pluma/pluma-1.26.0-r1.ebuild b/app-editors/pluma/pluma-1.26.0-r1.ebuild
new file mode 100644
index 000000000000..99286d9f6e29
--- /dev/null
+++ b/app-editors/pluma/pluma-1.26.0-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit mate python-single-r1 virtualx
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+IUSE="+introspection spell test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+ !!app-editors/mate-text-editor
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+MATE_FORCE_AUTORECONF=true
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fortify-source-3.patch
+)
+
+src_prepare() {
+ # Test require gvfs sftp fs mounted and schema's installed. Skip this one.
+ # https://github.com/mate-desktop/mate-text-editor/issues/33
+ sed -e '/+= document-saver/d' -i tests/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EPREFIX}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ local -x GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx emake check
+}