summaryrefslogtreecommitdiff
path: root/app-editors/pluma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-editors/pluma
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-editors/pluma')
-rw-r--r--app-editors/pluma/Manifest2
-rw-r--r--app-editors/pluma/pluma-1.22.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index 07a2d21776c1..9bee3808a316 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,3 +1,5 @@
DIST pluma-1.18.3.tar.xz 3355188 BLAKE2B d53f381aa9c74cad0df82ccc73aaab9f87347cb8e3886471a2531bdd4d49a84ee97a50f2333b2e375f9bc2a634c25dc69b36659dcb589ace716e523a9d0b4544 SHA512 62ad57a8d7626e34c15610e121869ee9b06a2498acb40ec0a60839ca0273d146bd59682d352c3e98d892460c444c5442d32673c2f63897bb8c3e9e595e771dc1
+DIST pluma-1.22.0.tar.xz 3235612 BLAKE2B a0cda23a6ee73e562cb32c3f1430590042248b6a6e7cbf021103db507450b2a594506f3d8283eeed08e2ba5006ff51376eb6db5e94ea5ac9d5707b29e0efc2c4 SHA512 7c74c2ce0a89ec3813c936449d3114957e7b319433875ef567ecc508a28a1d3ddc3d0da418b2eb1278b6dc9dbaa3c75a279524f5a061b5aecb52955edcf28f51
EBUILD pluma-1.18.3.ebuild 1762 BLAKE2B 5308bc86e3b681a3dd36fff0205dc4f45e4bbb1a490d135e975b38e1a66c400da7d3ee7014e34586d10ee5942e9366402a440d9cda2599e2dcbf256b524c1158 SHA512 8446e2f3c119ea9c1ed81b85265fc012c6d1990c5b12b56c9d3086e683c3b16b91e6e631c00f664b9027d60dfff1953b444e8135c9dc2af0da98eba6f0452b69
+EBUILD pluma-1.22.0.ebuild 1728 BLAKE2B 57c49c3aefc6f5e42258e718b8fe9ec6446750f62008e650a5ab88e0da1757708b99b4ae9c09936433f76fecf6253b1783ca9d12627ee2ab429894afa6acbe4b SHA512 87ab096902be646229adcf401f3edd1050829bdba64bffeeb216443fa7da48504c7272b7bf53ae541efde6027fabf731ade8b167ada9edd6bbf24d37507adca6
MISC metadata.xml 334 BLAKE2B 2d5ac79ba6879f5486724c826a89ed81cf393bc3fedbdea40764b1fb23962672e7c2a625137080a16ccd8e67a55097a4f497269f89ccd8b256490ef99e15b9cb SHA512 fe30c9986ed7086a894a0835847351d92938c424af5b7da51211a23fc197eebbce53cc205014cdd2c3bcc951a5a449c5d5726bede7991716d81fb7bbfe8a3fca
diff --git a/app-editors/pluma/pluma-1.22.0.ebuild b/app-editors/pluma/pluma-1.22.0.ebuild
new file mode 100644
index 000000000000..7033486f3273
--- /dev/null
+++ b/app-editors/pluma/pluma-1.22.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit mate python-single-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+introspection spell"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.2
+ >=app-text/iso-codes-0.35
+ )
+ !!app-editors/mate-text-editor"
+
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.9[introspection?]"
+
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.17:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}