summaryrefslogtreecommitdiff
path: root/app-editors/okteta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/okteta
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest5
-rw-r--r--app-editors/okteta/metadata.xml11
-rw-r--r--app-editors/okteta/okteta-0.25.1.ebuild66
-rw-r--r--app-editors/okteta/okteta-17.12.3.ebuild63
4 files changed, 145 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
new file mode 100644
index 000000000000..b96d27907cf1
--- /dev/null
+++ b/app-editors/okteta/Manifest
@@ -0,0 +1,5 @@
+DIST okteta-0.25.1.tar.xz 951952 BLAKE2B 180cb7426b85cc8598f774d50556fe26d95d11e7c8b5be542a38fd4fa1c0479b401e6be59e7ca86eabba805c2a5d2ea2d818960cb218d173fd87db23f9c5525f SHA512 67e594ee1674176cbf506ca1191ced748bf6aec268d57211e052552f9673c359ccb3fefd403b5cf63e04f63a4fd3b42b0d21ef8eefcbac999081d58505df2174
+DIST okteta-17.12.3.tar.xz 962772 BLAKE2B 4a347db4db1d248ccb73e2ab77d4b10449ccea2e1e23ae7770a338f1c96f3990de4a3362b566abde29d47ef4b1084614e219ea646e4b0704ecac048a4559d921 SHA512 d89bcd46001336d912f2d3f08247cdb13a02688316f078455e851feae03b638688683df2779c19089481b69baa2a582fd063d3180ebe66962ab249fc39c3850d
+EBUILD okteta-0.25.1.ebuild 1605 BLAKE2B 7c5a9e81733f75e9cd2ef29ce31a6c17cec9d8c49d90beeecb6407f73843b3a1a0009306dfd4e2e7d0d7620ccc1adbcbf6a1748a9e53b5858a7983c9c4617736 SHA512 82c9fc2dba9978f4671ab98d3b981377b94f5bb71c30050ff2a40e66852eda4f9fb2498289cbb402b0d2ad2d372c3d23d030c632a29cde25ae577588478782c7
+EBUILD okteta-17.12.3.ebuild 1600 BLAKE2B e68d7db197867765954cdd58adfb44574135aa17f5e2059cb67f6c79fd692317b9f6cf7c870a79b13223c6ccced6c96e5d29acddee915d950d6b64faf61f3b61 SHA512 6e58c656f55f854a4fe64579880f51a75d8f09bb656bb74784490fa91fa1e238a4c3e006c99fa3064187f65cfb7fe942cc9e049f943c2c55415c2e607a92475d
+MISC metadata.xml 340 BLAKE2B a8e14dd471ebcdaf382d71d9dec13809433c811acbc813ea4c74b1cd05829474df09efba54d8e3aa1041bce3f5e4a61db879e228bab4f79e3b4d9eed32e40a25 SHA512 c6fa7ef3ff6e38f17ef6db3784bfe04e35607464521488253d03863919392c38e76b7d4cf92e83502b1bec109fa1b1a257a7e4a955ea2c01d61e1784f89f59ae
diff --git a/app-editors/okteta/metadata.xml b/app-editors/okteta/metadata.xml
new file mode 100644
index 000000000000..a50ada50ef0e
--- /dev/null
+++ b/app-editors/okteta/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <use>
+ <flag name="designer">Build plugins for <pkg>dev-qt/designer</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-editors/okteta/okteta-0.25.1.ebuild b/app-editors/okteta/okteta-0.25.1.ebuild
new file mode 100644
index 000000000000..89727e9e83b1
--- /dev/null
+++ b/app-editors/okteta/okteta-0.25.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}
diff --git a/app-editors/okteta/okteta-17.12.3.ebuild b/app-editors/okteta/okteta-17.12.3.ebuild
new file mode 100644
index 000000000000..fa883ad1b7c3
--- /dev/null
+++ b/app-editors/okteta/okteta-17.12.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+SRC_URI="mirror://kde/stable/applications/${PV}/${P}.tar.xz"
+KEYWORDS="amd64 x86"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ $(cmake-utils_use_find_package designer Qt5Designer)
+ $(cmake-utils_use_find_package designer Qt5UiPlugin)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}