summaryrefslogtreecommitdiff
path: root/app-editors/neovim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 01:11:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 01:11:37 +0000
commitb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (patch)
tree11a204a4a8687d1677d7b04ddda4a236c755528e /app-editors/neovim
parent73f18fd49d6fabbb1dc8721e38adaa18d55b8c95 (diff)
gentoo auto-resync : 25:11:2022 - 01:11:36
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch61
2 files changed, 0 insertions, 62 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 28b863339e9d..ac623c3fd8df 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,4 +1,3 @@
-AUX neovim-0.4.4-cmake-darwin.patch 2599 BLAKE2B 7d5d5298f3b32385bcd17c582865f554edf8f1a164517dfd802590f8f7f85b3cbcce2ae7ffdd9163fa87b55000a582129b6fb93835decff135f0029c1f8cc681 SHA512 1b4f5b1baaecacb807c6c2d022dd17c887f4a6236c3d452fdc9e01c3e1a868ca395e727343bfe793bf9a667889e22413683e3a196d8aaa4f978514b91634c849
AUX neovim-0.4.4-cmake-release-type.patch 627 BLAKE2B 87c6e6fd487b923ec4146f2cb38a9a30be00ffa7b9d0a41b43f17d4f79860e4f097b76e093af474dfe20538332a7c6f233ebd57d845a74d7a8aead9cae2fec76 SHA512 b236c0b703ec2763a1179149715fa241573803a27dcb05324e2f766f49aaf53dfe0efc62f1c10aa6d58333ce115835e852608778d9582689550fb537103f361a
AUX neovim-0.4.4-cmake_lua_version.patch 419 BLAKE2B 73477d7fdc2705f2e93cd6dd355ea01fbfc232306e86a13097a1c069ea3248972be9d4da7b175c8c3c7e0fde7581d4ed9b431d73c119e9f8a63a7a15007aba31 SHA512 a1be27ebd18be34fede632f695bacf65699e9dd1a8b219120372b5e0c48691f595ba42725c4f795456b8018d668f471e3a042622a5f541af50c84a089d53c83c
AUX neovim-0.7.2-cmake-darwin.patch 2418 BLAKE2B 8b80ddeedbb96d58301045f7512f9fff3dd682571c4f2cd9de57d9587efed7af5d7a44a081385d2a122b9ff456149087869f788008435311a9e21dd6c0d411bd SHA512 e5393466a3c4ac0db593f664b956bb1683f4e341c00de8b145599dbf7d0f5300c6169415ca44af21cccd8393a82747db6e0ba5cb5086a24ca5f7d82c1d1bdfd8
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
deleted file mode 100644
index 4fa8bf45bcbd..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 07928e3..08881ee 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -58,23 +58,6 @@ endif()
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Enable fixing case-insensitive filenames for Windows and Mac.
- set(USE_FNAME_CASE TRUE)
-diff --git a/src/nvim/CMakeLists.txt b/src/nvim/CMakeLists.txt
-index aa81008..0570dc7 100644
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -192,10 +192,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
-diff --git a/third-party/CMakeLists.txt b/third-party/CMakeLists.txt
-index edd5882..e503434 100644
---- a/third-party/CMakeLists.txt
-+++ b/third-party/CMakeLists.txt
-@@ -105,13 +105,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- # Cross compiling: use these for dependencies built for the
- # HOST system, when not crosscompiling these should be the
- # same as DEPS_*. Except when targeting Unix in which case \ No newline at end of file