summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 07:10:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 07:10:13 +0100
commit42ff81a7480d9bba317b42fcca03b46da2a622ce (patch)
tree5a0ccbe2b71a4ec6c160b568160999a6afe316de /app-editors/neovim/neovim-9999.ebuild
parent290844d409ace33d948956aec3c542ea6f4a7b13 (diff)
gentoo auto-resync : 01:10:2022 - 07:10:12
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index c1e19411b835..2e5948e10f45 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -32,6 +32,7 @@ RESTRICT="!test? ( test ) test"
# Upstream build scripts invoke the Lua interpreter
BDEPEND="${LUA_DEPS}
>=dev-util/gperf-3.1
+ >=sys-devel/gettext-0.20.1
virtual/libiconv
virtual/libintl
virtual/pkgconfig
@@ -39,7 +40,7 @@ BDEPEND="${LUA_DEPS}
# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
DEPEND="${LUA_DEPS}
- >=dev-lua/luv-1.43.0[${LUA_SINGLE_USEDEP}]
+ >=dev-lua/luv-1.44.2[${LUA_SINGLE_USEDEP}]
$(lua_gen_cond_dep '
dev-lua/lpeg[${LUA_USEDEP}]
dev-lua/mpack[${LUA_USEDEP}]
@@ -47,10 +48,10 @@ DEPEND="${LUA_DEPS}
$(lua_gen_cond_dep '
dev-lua/LuaBitOp[${LUA_USEDEP}]
' lua5-{1,2})
- >=dev-libs/libuv-1.44.1:=
- >=dev-libs/libvterm-0.1.4
+ >=dev-libs/libuv-1.44.2:=
+ >=dev-libs/libvterm-0.3
>=dev-libs/msgpack-3.0.0:=
- >=dev-libs/tree-sitter-0.20.6:=
+ >=dev-libs/tree-sitter-0.20.2:=
tui? (
>=dev-libs/libtermkey-0.22
>=dev-libs/unibilium-2.0.0:0=
@@ -76,9 +77,9 @@ if [[ ${PV} == 9999 ]]; then
)
else
PATCHES+=(
- "${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
- "${FILESDIR}/${PN}-0.7.2-cmake-darwin.patch"
+ "${FILESDIR}/${PN}-9999-cmake_lua_version.patch"
+ "${FILESDIR}/${PN}-9999-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-9999-cmake-darwin.patch"
)
fi