summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /app-editors/neovim/files
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch13
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch55
3 files changed, 0 insertions, 79 deletions
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
deleted file mode 100644
index 2c9c80a7a690..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake-release-type.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Ensure that :checkhealth is happy with the Gentoo build type.
-https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -118,7 +118,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
deleted file mode 100644
index 4703dee52613..000000000000
--- a/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -384,7 +384,7 @@
- option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
- if(PREFER_LUA)
-- find_package(Lua 5.1 REQUIRED)
-+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
deleted file mode 100644
index a8404bd4a97a..000000000000
--- a/app-editors/neovim/files/neovim-0.7.2-cmake-darwin.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
---- a/third-party/CMakeLists.txt
-+++ b/third-party/CMakeLists.txt
-@@ -117,13 +117,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags