summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
commitd05150f06fa67b115a83f822b1e285dca011e1b7 (patch)
tree86d728b5108b361faf2f421e2d4f3b03a85b7837 /app-editors/neovim/files/neovim-9999-cmake-release-type.patch
parentbe524496e3171d5eab8c56570dd4342a880c3264 (diff)
gentoo auto-resync : 02:11:2022 - 21:10:25
Diffstat (limited to 'app-editors/neovim/files/neovim-9999-cmake-release-type.patch')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-release-type.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
index 8114e2a92b74..8c24b6b6123f 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-release-type.patch
@@ -1,16 +1,16 @@
Ensure that :checkhealth is happy with the Gentoo build type.
https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -135,7 +135,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
+--- a/runtime/lua/nvim/health.lua
++++ b/runtime/lua/nvim/health.lua
+@@ -149,7 +149,7 @@ local function check_performance()
+ let s:buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
+ if empty(s:buildtype)
+ call health#report_error('failed to get build type from :version')
+- elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
++ elseif s:buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
+ call health#report_ok(s:buildtype)
+ else
+ call health#report_info(s:buildtype)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,12 +137,6 @@ else()