summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
commitb392cbf078526e18db5d54ec37f9580be480fd48 (patch)
treef2f8f60717bb0fbe3df7452c2e0b1e0c192341d1 /app-editors/neovim/files/neovim-9999-cmake-darwin.patch
parentcd40bc9ab405aca4e72f869db79d9d1ff77d8313 (diff)
gentoo auto-resync : 13:08:2022 - 14:24:01
Diffstat (limited to 'app-editors/neovim/files/neovim-9999-cmake-darwin.patch')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index 5b829904a13e..cf3e05716625 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -80,23 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
+@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
# used for check_c_compiler_flag
include(CheckCCompilerFlag)
@@ -13,6 +13,16 @@
- # them be included as one of the first places to look for dependencies.
- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
-
+- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
+- # fall back to local system version. Needs to be done both here and in cmake.deps.
+- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
+- execute_process(COMMAND sw_vers -productVersion
+- OUTPUT_VARIABLE MACOS_VERSION
+- OUTPUT_STRIP_TRAILING_WHITESPACE)
+- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
+- endif()
+- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
+-
- # Work around some old, broken detection by CMake for knowing when to use the
- # isystem flag. Apple's compilers have supported this for quite some time
- # now.
@@ -42,7 +52,7 @@
# The LuaJIT build does not like being passed multiple `-arch` flags
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -205,10 +205,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()