summaryrefslogtreecommitdiff
path: root/app-editors/nano/nano-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /app-editors/nano/nano-9999.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'app-editors/nano/nano-9999.ebuild')
-rw-r--r--app-editors/nano/nano-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 0aed36a7b0ee..2b29359919a7 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
inherit git-r3 autotools
else
- MY_P=${PN}-${PV/_}
+ MY_P="${PN}-${PV/_}"
SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -32,10 +32,10 @@ DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
src_prepare() {
+ default
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
- default
}
src_configure() {
@@ -64,7 +64,7 @@ src_configure() {
src_install() {
default
- rm -rf "${D}"/trash
+ rm -rf "${ED%/}"/trash
dodoc doc/sample.nanorc
docinto html
@@ -78,6 +78,5 @@ src_install() {
"${ED%/}"/etc/nanorc || die
fi
- dodir /usr/bin
dosym ../../bin/nano /usr/bin/nano
}