summaryrefslogtreecommitdiff
path: root/app-editors/mousepad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
commit590b9b7b03bf4651e099949e318755af7cfa81b8 (patch)
tree54c184b7d26c25f1922bfeaf19a1dd45a2e3b1eb /app-editors/mousepad
parentf4fc10428424904caf2035cffc442195cb088b2c (diff)
gentoo resync : 01.08.2021
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/mousepad-0.5.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 9501190e0c43..79823268d587 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.5.5.tar.bz2 891263 BLAKE2B a75930385f9087f6294811c91b2a162d2e9ca2e945ec84efdfd932806211ee105d2ac2835122c2de4ea519b6728959478147d11df75ff3b00324c262983046a0 SHA512 5c6d6d048fe8a08c04ddeff7adb7d621d9beac631dd58fe5778cc8236e06ddb4ab50380eaebf4236c655b6d26058242024d5d3bbb1772607ab1f10744f8936f1
+DIST mousepad-0.5.6.tar.bz2 916738 BLAKE2B 59506a5eb362259889e580de52ed3135c339da4148dc1c99d7c7e6aee04d776f7ef67959a54aabfa29b7b174279f205cdaa0932199b407528019def24c4915c4 SHA512 24e974f793fd8660d39fc00156f8f8f07bae44133c6f58d705b1665f0b8d333f2248a6780b48794edb56e7faf7f206069a7866f76cbf91f6ce6b8b2ac7121f34
EBUILD mousepad-0.5.5.ebuild 863 BLAKE2B 02de904b60dbf85fa7f8160671d1be6fc48590b9f6acbdf8112398485d6f367b9d9e6e8bbf041f75887f3eb49071f530d5d8342fa67c207113b86b80cfa2d58a SHA512 de8269ab6791e78318a257c9e52678db31e996c2bd0cb37b36dda062dbb1ec33f243f70f365cd2690815241bf7021b80e9ab866bdbbd9249d63e484cf13facc8
+EBUILD mousepad-0.5.6.ebuild 865 BLAKE2B 6d8b99afce428bd8ddfe3b9e170aeff47c2198ae5be94f5b8b0fb4a5051365547150a9819d3ed948df2b4330e26d37485bd4bf7d143fb5836a24beca29eda12c SHA512 c33da95d6f6ef47dbdb4b10d4381a95259a19d7e33d8ba6895b6749a7c2efca304614aa05dc394f6e005d4dd89d951eb83dffbeb336caf491791db09916e456b
MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/app-editors/mousepad/mousepad-0.5.6.ebuild b/app-editors/mousepad/mousepad-0.5.6.ebuild
new file mode 100644
index 000000000000..1dee543de886
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.52
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}