summaryrefslogtreecommitdiff
path: root/app-editors/mousepad/mousepad-0.4.90.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-editors/mousepad/mousepad-0.4.90.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-editors/mousepad/mousepad-0.4.90.ebuild')
-rw-r--r--app-editors/mousepad/mousepad-0.4.90.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/mousepad/mousepad-0.4.90.ebuild b/app-editors/mousepad/mousepad-0.4.90.ebuild
new file mode 100644
index 000000000000..8d5d963fcc26
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.90.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.45.8:2=
+ >=xfce-base/xfconf-4.12:=
+ >=x11-libs/gtk+-3.20:3=
+ x11-libs/gtksourceview:3.0="
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}