summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/kakoune-2021.11.08-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-editors/kakoune/kakoune-2021.11.08-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-editors/kakoune/kakoune-2021.11.08-r1.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2021.11.08-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2021.11.08-r1.ebuild b/app-editors/kakoune/kakoune-2021.11.08-r1.ebuild
new file mode 100644
index 000000000000..37633ce21f75
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2021.11.08-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc12.patch
+)
+
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake -C src all
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}