summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-editors/kakoune/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-editors/kakoune/files')
-rw-r--r--app-editors/kakoune/files/kakoune-0_pre20170523-makefile.patch31
-rw-r--r--app-editors/kakoune/files/kakoune-makefile.patch40
2 files changed, 71 insertions, 0 deletions
diff --git a/app-editors/kakoune/files/kakoune-0_pre20170523-makefile.patch b/app-editors/kakoune/files/kakoune-0_pre20170523-makefile.patch
new file mode 100644
index 000000000000..b30238d6f943
--- /dev/null
+++ b/app-editors/kakoune/files/kakoune-0_pre20170523-makefile.patch
@@ -0,0 +1,31 @@
+diff --git a/src/Makefile b/src/Makefile
+index dbef95d9..70f16b32 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,7 +6,6 @@ ifeq ($(debug),yes)
+ suffix := .debug
+ else
+ ifeq ($(debug),no)
+- CXXFLAGS += -O3
+ suffix := .opt
+ else
+ $(error debug should be either yes or no)
+@@ -22,8 +21,6 @@ mandocs := $(docs:.asciidoc=.gz)
+ PREFIX ?= /usr/local
+ DESTDIR ?= # root dir
+
+-NCURSESW_INCLUDE ?= /usr/include/ncursesw
+-
+ bindir := $(DESTDIR)$(PREFIX)/bin
+ sharedir := $(DESTDIR)$(PREFIX)/share/kak
+ docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
+@@ -49,8 +46,7 @@ else ifneq (,$(findstring CYGWIN,$(os)))
+ CPPFLAGS += -D_XOPEN_SOURCE=700
+ LIBS += -lncursesw -lboost_regex -ldbghelp
+ else
+- LIBS += -lncursesw -lboost_regex
+- CPPFLAGS += -I$(NCURSESW_INCLUDE)
++ LIBS += -lboost_regex
+ LDFLAGS += -rdynamic
+ endif
+
diff --git a/app-editors/kakoune/files/kakoune-makefile.patch b/app-editors/kakoune/files/kakoune-makefile.patch
new file mode 100644
index 000000000000..54a22d5ac925
--- /dev/null
+++ b/app-editors/kakoune/files/kakoune-makefile.patch
@@ -0,0 +1,40 @@
+diff --git a/src/Makefile b/src/Makefile
+index c79c270..9409a8c 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,10 +3,10 @@ pedantic ?= yes
+
+ ifeq ($(debug),yes)
+ CPPFLAGS += -DKAK_DEBUG
++ CXXFLAGS += -g
+ suffix := .debug
+ else
+ ifeq ($(debug),no)
+- CXXFLAGS += -O3
+ suffix := .opt
+ else
+ $(error debug should be either yes or no)
+@@ -26,8 +26,6 @@ mandocs := $(docs:.asciidoc=.gz)
+ PREFIX ?= /usr/local
+ DESTDIR ?= # root dir
+
+-NCURSESW_INCLUDE ?= /usr/include/ncursesw
+-
+ bindir := $(DESTDIR)$(PREFIX)/bin
+ sharedir := $(DESTDIR)$(PREFIX)/share/kak
+ docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
+@@ -53,11 +51,10 @@ else ifneq (,$(findstring CYGWIN,$(os)))
+- LIBS += -lncursesw -lboost_regex -ldbghelp
++ LIBS += -lboost_regex -ldbghelp
+ else
+- LIBS += -lncursesw -lboost_regex
++ LIBS += -lboost_regex
+- CPPFLAGS += -I$(NCURSESW_INCLUDE)
+ LDFLAGS += -rdynamic
+ endif
+
+-CXXFLAGS += -std=gnu++11 -g -Wall -Wno-reorder -Wno-sign-compare -Wno-address
++CXXFLAGS += -std=gnu++11 -Wall -Wno-reorder -Wno-sign-compare -Wno-address
+
+ kak : $(objects)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) $(objects) $(LIBS) -o $@