summaryrefslogtreecommitdiff
path: root/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/juffed/juffed-0.10_p20160323-r1.ebuild')
-rw-r--r--app-editors/juffed/juffed-0.10_p20160323-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
new file mode 100644
index 000000000000..97e18f2d896c
--- /dev/null
+++ b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=5ba17f90ec173e773470bc80ea26bca9a3f093fd
+inherit cmake-utils vcs-snapshot xdg-utils
+
+DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
+HOMEPAGE="http://juffed.com/en/"
+SRC_URI="https://github.com/Mezomish/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-i18n/enca
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=x11-libs/qscintilla-2.9.4:=[qt5(+)]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-qscintilla-2.10.patch"
+ "${FILESDIR}/${P}-qt-5.11.patch"
+)
+
+src_prepare() {
+ # Upstream version outdated/dysfunctional and CRLF terminated
+ cp "${FILESDIR}"/FindQtSingleApplication.cmake cmake/ || die
+
+ cmake-utils_src_prepare
+
+ sed -i -e '/set(CMAKE_CXX_FLAGS/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DUSE_ENCA=ON
+ -DUSE_QT5=ON
+ -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
+ -DLIB_SUFFIX=${libdir/lib/}
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}