summaryrefslogtreecommitdiff
path: root/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-editors/juffed/juffed-0.10_p20160323-r1.ebuild')
-rw-r--r--app-editors/juffed/juffed-0.10_p20160323-r1.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
index 97e18f2d896c..955c950bbf9e 100644
--- a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
+++ b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
COMMIT=5ba17f90ec173e773470bc80ea26bca9a3f093fd
-inherit cmake-utils vcs-snapshot xdg-utils
+inherit cmake xdg
DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
HOMEPAGE="http://juffed.com/en/"
@@ -29,16 +29,19 @@ DEPEND="${RDEPEND}"
DOCS=( ChangeLog README )
+S="${WORKDIR}/Mezomish-${PN}-5ba17f9"
+
PATCHES=(
"${FILESDIR}/${P}-qscintilla-2.10.patch"
"${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-qscintilla-2.10.3.patch"
)
src_prepare() {
# Upstream version outdated/dysfunctional and CRLF terminated
cp "${FILESDIR}"/FindQtSingleApplication.cmake cmake/ || die
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e '/set(CMAKE_CXX_FLAGS/d' CMakeLists.txt || die
}
@@ -51,15 +54,5 @@ src_configure() {
-DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
-DLIB_SUFFIX=${libdir/lib/}
)
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
+ cmake_src_configure
}