summaryrefslogtreecommitdiff
path: root/app-editors/hexedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/hexedit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest4
-rw-r--r--app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch10
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild30
-rw-r--r--app-editors/hexedit/metadata.xml8
4 files changed, 52 insertions, 0 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
new file mode 100644
index 000000000000..57b2776eb3ff
--- /dev/null
+++ b/app-editors/hexedit/Manifest
@@ -0,0 +1,4 @@
+AUX hexedit-1.2.13-tinfo.patch 329 BLAKE2B b82e7b0495a8ccac367501f530d52f8b2988a242206efd25e14c433a25e1742c2bc3d0c7b1d1613ec8beec530264ce7fb177f2d3d9338c90eaf921a366726a66 SHA512 21306eddc00720a22365b84181581bc89db2a1d422cf769c2b29585144ab87064a19696ba946e16cc56e2d2d45aa12ebb88b3054ea0167124d960afdaa5a7d8a
+DIST hexedit-1.2.13.src.tgz 68778 BLAKE2B 377c4f0008f6e3b54e4cf2e0249fa344b684b11a6acea9daf7d8e6585524f9d11a4eb199d5289a57a72be5efbdf3060cc47269aad1d218784e7679a469ca4f50 SHA512 df9afb0b9b965e20ea8c427c1986b0200216601b157862199c35bae9e201ccc478ab0bfecd39d0dfaa85bf582f1cf372b0134fadcfeacf4734805a6e6dcaa2bb
+EBUILD hexedit-1.2.13.ebuild 698 BLAKE2B 89e3f6426b44847b7cdd5db5e0e67a840c3cdf7760f8657f8b1ddbd0d7a61e4ba9f37c43f22dddba1593939a928cf870fff627d960ed7d36ecd7bf053b7c5598 SHA512 fc82df639c0165215f4864d377e0610d096a29146b3949c5da34b14fcaa6140464072fafdb269b5662e56ece388d3aa092cea6dc36f624a060d34dcc150f8d75
+MISC metadata.xml 249 BLAKE2B d6fa8a349066f9684c68c3086f53e41ebf30b6e313e8e8e752a953c0eaa0853448fe17e5ed46836bc5e149a282a33c7408c675d3b39eb3d59ddc1c1ad86bf716 SHA512 965ae00fa198dd8f5869c4c14ff3e28c7d76be7182be6ba4bedbb68d7138da5be3c8bb993689db2c73ac328456015ebdf018ee1b308d6988067810d1156bd179
diff --git a/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
new file mode 100644
index 000000000000..86e7dba4e88e
--- /dev/null
+++ b/app-editors/hexedit/files/hexedit-1.2.13-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -37,6 +37,7 @@
+ AC_CHECK_LIB(curses, initscr, LIBS="$LIBS -lcurses",
+ AC_CHECK_LIB(ncurses, initscr, LIBS="$LIBS -lncurses")
+ )
++AC_SEARCH_LIBS(nodelay, tinfo)
+ AC_CHECK_FUNC(use_default_colors,
+ AC_DEFINE(HAVE_COLORS, , "Define if you want colored (fruit salad) display option")
+ )
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
new file mode 100644
index 000000000000..6bf3c4700dec
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+SRC_URI="http://rigaux.org/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}
diff --git a/app-editors/hexedit/metadata.xml b/app-editors/hexedit/metadata.xml
new file mode 100644
index 000000000000..4e80019694b1
--- /dev/null
+++ b/app-editors/hexedit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>