summaryrefslogtreecommitdiff
path: root/app-editors/hexedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-editors/hexedit
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest4
-rw-r--r--app-editors/hexedit/hexedit-1.5.ebuild34
-rw-r--r--app-editors/hexedit/metadata.xml4
3 files changed, 41 insertions, 1 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
index 846953df38f0..232b42e277cf 100644
--- a/app-editors/hexedit/Manifest
+++ b/app-editors/hexedit/Manifest
@@ -1,4 +1,6 @@
AUX hexedit-1.2.13-tinfo.patch 329 BLAKE2B b82e7b0495a8ccac367501f530d52f8b2988a242206efd25e14c433a25e1742c2bc3d0c7b1d1613ec8beec530264ce7fb177f2d3d9338c90eaf921a366726a66 SHA512 21306eddc00720a22365b84181581bc89db2a1d422cf769c2b29585144ab87064a19696ba946e16cc56e2d2d45aa12ebb88b3054ea0167124d960afdaa5a7d8a
DIST hexedit-1.2.13.src.tgz 68778 BLAKE2B 377c4f0008f6e3b54e4cf2e0249fa344b684b11a6acea9daf7d8e6585524f9d11a4eb199d5289a57a72be5efbdf3060cc47269aad1d218784e7679a469ca4f50 SHA512 df9afb0b9b965e20ea8c427c1986b0200216601b157862199c35bae9e201ccc478ab0bfecd39d0dfaa85bf582f1cf372b0134fadcfeacf4734805a6e6dcaa2bb
+DIST hexedit-1.5.tar.gz 30544 BLAKE2B d7292a70819826fddd63f99ee9d05073b8a59f51477390af91151146ee1f5a75333560829f0351fa9e158ef932c07a3582a3e822f42e645917a7fa321055d14e SHA512 9d8e5c8c0cda0af17ffeaf528e3dacd7fc2878dfc0755cb055dae5c56f05c961353c1d1723b05897314b49a44a6eb96de5d3a599c6b29967425507eea7cc7ca5
EBUILD hexedit-1.2.13.ebuild 702 BLAKE2B b2baa82ded8ca1e5d01f83aa763a4df04f527b653ac3bc8d7063974f684082dfc0a2276a505d28dbeb5a5085ab8feb1281c4dab40aa9e39290600ab47146e1a7 SHA512 1e8acb13a25382648b5593e75a347f954e3f229f3cd44d85d9b877a2bc140df3aae80defa708778db9e2d32879859efb41a33f1f2bbaff5abf71a5562c5f9834
-MISC metadata.xml 250 BLAKE2B 73afdd27824ddad49c748f845fb81e8b64d10b29a271175198b7c893096d6d5c64bf736446ec01c9679b7978925de4df8159761e1c3fdb83436468c882a72f85 SHA512 f5d1c70de88ecdf2edd6f5d68f44e26fd99705a91c52269b39c03240b06ab1d8299d03a2af5828c8f22198ec1188f14f957064c8459f27a8f2efea25398bdf4d
+EBUILD hexedit-1.5.ebuild 742 BLAKE2B 9aea766dfb83143edbfed9386543a3d22a87b3b51ffce305eb681860e3ce10a8bbb94841bd7c141369777ef11cf30e7ebd59034e7ee976d747d1ea1b4519e1cd SHA512 f444f0490ed304a0c7e4962295f269fe1ab6010cb248d67ebdb2ec23caa049153f0caa9f4dde09f7d1b274e95acf5331703bf97196e6c39fba36b9109a02ec19
+MISC metadata.xml 351 BLAKE2B 0c74729ae34fd37946be2b370ec986ea6f894cc13c642865030ad8857b65bb5900cf3b822e2c9b16bfc33df955e3d747622dddf6b5344a5edd867a236988135a SHA512 1878b5fb1fe6d7e0c6af3a433d9dfd8e9f365a4bf52d15ff5aa01e4f8153924b6379edee442d98f2c0282fd19f7141ffc77d0ce53e8dd1428e5ac90643f84c9e
diff --git a/app-editors/hexedit/hexedit-1.5.ebuild b/app-editors/hexedit/hexedit-1.5.ebuild
new file mode 100644
index 000000000000..7da44e6f5b51
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}
diff --git a/app-editors/hexedit/metadata.xml b/app-editors/hexedit/metadata.xml
index 001997549c54..4495c367e89c 100644
--- a/app-editors/hexedit/metadata.xml
+++ b/app-editors/hexedit/metadata.xml
@@ -5,4 +5,8 @@
<email>tomjbe@gentoo.org</email>
<name>Thomas Beierlein</name>
</maintainer>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
</pkgmetadata>