summaryrefslogtreecommitdiff
path: root/app-editors/hexedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-editors/hexedit
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest2
-rw-r--r--app-editors/hexedit/hexedit-1.6.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
index 382bbdde2e58..e882b41ef61c 100644
--- a/app-editors/hexedit/Manifest
+++ b/app-editors/hexedit/Manifest
@@ -1,3 +1,5 @@
DIST hexedit-1.5.tar.gz 30544 BLAKE2B d7292a70819826fddd63f99ee9d05073b8a59f51477390af91151146ee1f5a75333560829f0351fa9e158ef932c07a3582a3e822f42e645917a7fa321055d14e SHA512 9d8e5c8c0cda0af17ffeaf528e3dacd7fc2878dfc0755cb055dae5c56f05c961353c1d1723b05897314b49a44a6eb96de5d3a599c6b29967425507eea7cc7ca5
+DIST hexedit-1.6.tar.gz 31085 BLAKE2B e576de6aaed35449adbc430c95e8ba3a8ccfba587ef5c4d347d95b84c9764cb644323af23d46ff16429b93e0348c8d310afbad482219aa1b2c1b582332bd06fe SHA512 9783406f253a67fe048ec12306df1a601b7ba92cd7a0399ad2f103aed5a3164cd21ad7c1d547a4c55192cfb7da2b2517152015a4c3db402a9217548b435f602d
EBUILD hexedit-1.5.ebuild 735 BLAKE2B ce7ae724f31b951a7a9e695274dbb82e3db4a517da61a35c69fe2dc20df6b8ba2f0f1658bf9a4d957bd309de42eaa9ee6312e2dbadc78ee59eccfd3951c1622a SHA512 34cc7032c292ed1aa1474afae9c524df3f532335f42c64d94e21ffc191c0d127b356b51b6940c7849b1e8b41d27c281d6474aa546607b0482a7b3657764744af
+EBUILD hexedit-1.6.ebuild 742 BLAKE2B 9aea766dfb83143edbfed9386543a3d22a87b3b51ffce305eb681860e3ce10a8bbb94841bd7c141369777ef11cf30e7ebd59034e7ee976d747d1ea1b4519e1cd SHA512 f444f0490ed304a0c7e4962295f269fe1ab6010cb248d67ebdb2ec23caa049153f0caa9f4dde09f7d1b274e95acf5331703bf97196e6c39fba36b9109a02ec19
MISC metadata.xml 351 BLAKE2B 0c74729ae34fd37946be2b370ec986ea6f894cc13c642865030ad8857b65bb5900cf3b822e2c9b16bfc33df955e3d747622dddf6b5344a5edd867a236988135a SHA512 1878b5fb1fe6d7e0c6af3a433d9dfd8e9f365a4bf52d15ff5aa01e4f8153924b6379edee442d98f2c0282fd19f7141ffc77d0ce53e8dd1428e5ac90643f84c9e
diff --git a/app-editors/hexedit/hexedit-1.6.ebuild b/app-editors/hexedit/hexedit-1.6.ebuild
new file mode 100644
index 000000000000..7da44e6f5b51
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}