summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-editors/gedit-plugins
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-42.0.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 307a41e977bc..bb7e5ea36a12 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-41.0.tar.xz 948364 BLAKE2B d5efe779e1f0f70e23a7dadb01b0e5b22c47d3326df6530559698ace274e2a4a3647d34640e89bb250d76bee1f6369d5728316730ce9cf89f3a7db627b3c4d49 SHA512 e0389e8be68406fdcd3c9537b2d2dad0faf19d9a49804a7b5d9cf8e1006254906605dd0b14e2fa1eb7a22d6533d9b55d7f5593fe01a5b412df6361c8b9089f34
+DIST gedit-plugins-42.0.tar.xz 949068 BLAKE2B d9076d7ef420177b5d859bdee651b4304da183430d651510ea4ab50bc7286d23f536c1be47e6a6f425bdf90dcb31f015fa315e9ed530d54eb235832d92c4f438 SHA512 b7b6b6c71538ca767e20e4bdde0a5530657bf3d444fee5e1b2918b768188f224acfd2a44c4b0b6203ee3bde9ec47d2bacb0e25426cf49e500120461d44ae6b9a
EBUILD gedit-plugins-41.0.ebuild 2717 BLAKE2B 5ca39394512387999dc672d688372a43f29ba1ce410e8f0c7654a478780caa614a61fb949fff8293d3e58b5c022d8adbc405b7d481bb8924966a32ed4a274c8f SHA512 d79253703e9bfcb340937608c6382131a545735fcd4dbc6a9282a97c914f68a4b1de28c24c7da6a0397681ad04e5376fdbd7c1e974e8896097848b073d7e176b
+EBUILD gedit-plugins-42.0.ebuild 2728 BLAKE2B 7c6899d997fe6f337d97930ac5c696622cc58d6e458a039d8511516b741201476cdc9ab65f8daf6b3231cae7518ee0fad46f6b4b87cb0cabc09aa75d800e0dbf SHA512 704bbdd88b0bd4586ceec5fe28f592b11b2d0795fbc507194d5da6f21834485909e72c3547c07c8b2ce9c9da39267797265c7f129c3bd81e18cb54c857c24e06
MISC metadata.xml 481 BLAKE2B 5fbf2df78aa40fce971741bb7d04de00cdc7a6371c2652ae0ae4bf253ee469c4bbb5e5a7c2b88226f95bb8865930dd19e9adedb191fd5a173ce915890ce40b32 SHA512 3b4b858659d1597e6c1ee574143de4864be8b75d4a6399d47bff85c4b18ec35472523bfeaa0815189a9008764405ee3b2fa53e73fcdc3edc8eda00a5f943f762
diff --git a/app-editors/gedit-plugins/gedit-plugins-42.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-42.0.ebuild
new file mode 100644
index 000000000000..092e6a590b14
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-42.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-40.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ $(meson_use python plugin_commander)
+ -Dplugin_drawspaces=true
+ $(meson_use vala plugin_findinfiles)
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ $(meson_use python plugin_translate)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}