summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/gedit-plugins
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest3
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild94
-rw-r--r--app-editors/gedit-plugins/metadata.xml15
3 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
new file mode 100644
index 000000000000..3c6925e0c47b
--- /dev/null
+++ b/app-editors/gedit-plugins/Manifest
@@ -0,0 +1,3 @@
+DIST gedit-plugins-3.22.0.tar.xz 1314512 BLAKE2B 2910a101da94112b4190d96111013675234c109bfc37e05ff98d53e87e0a4db8e5a4a6823017153d65a9d554cfb95fed000d56d9e721faebfeeb033fc7be2901 SHA512 5560b48c0b21b535de7247c39653c111439f9cb138025d7e3a600b94babbe060777c2095160b7e5ea39b8ba8be520ea3966b0ffc2ec15d17ea0bf814bf58748d
+EBUILD gedit-plugins-3.22.0.ebuild 2297 BLAKE2B 74878dee069c2eeed548f80084f2bf1b63cedeab159ab84b54bd2bde7ae5446b5b6facb77e0cc08184a6bfd7502508bd0e5e6130c412247b822233fdae060ada SHA512 dce1562f0c1882d55feec31b82f3261d5e026f1e7fc1eb295941769c2da57d4feba03637f266f2a370fa5efb9f33b90253900eb40ad1d065b2762a6f08ea9ad2
+MISC metadata.xml 542 BLAKE2B 1336fdd161ef76bb2e1445dd074aed82e04be00c9c47885eb5005122c850193dd2bec1aed69dd1da74527c8ee82d7c75d57b73d020cc692e41f6762ba43d8f08 SHA512 1eba6ba724a313d8dd04e838c448cb8de2f3411b891daaacdea615f0d8187d3bbe1f650c9b2ab5457d519ed98dee600d8830e7eea848c872ccb9c52ba58f231a
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
new file mode 100644
index 000000000000..676c4d9aa014
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit eutils gnome2 multilib python-single-r1 vala
+
+DESCRIPTION="Official plugins for gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="amd64 x86"
+SLOT="0"
+
+IUSE_plugins="charmap git terminal vala"
+IUSE="+python ${IUSE_plugins}"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=app-editors/gedit-3.16
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-1.7.0[gtk]
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-3.21.3:3.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-editors/gedit-3.16[introspection,python,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-3.14:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6 )
+ terminal? ( x11-libs/vte:2.91[introspection] )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable vala)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # FIXME: crazy !!!
+ if use python; then
+ find "${ED}"/usr/share/gedit -name "*.py*" -delete || die
+ find "${ED}"/usr/share/gedit -type d -empty -delete || die
+ fi
+
+ # FIXME: upstream made this automagic...
+ clean_plugin charmap
+ clean_plugin git
+ clean_plugin terminal
+}
+
+clean_plugin() {
+ if use !${1} ; then
+ rm -rf "${ED}"/usr/share/gedit/plugins/${1}*
+ rm -rf "${ED}"/usr/$(get_libdir)/gedit/plugins/${1}*
+ fi
+}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
new file mode 100644
index 000000000000..0b4585984564
--- /dev/null
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<longdescription>Official plugins for gedit</longdescription>
+<use>
+ <flag name="charmap">Insert special characters just by clicking on
+ them</flag>
+ <flag name="git">Shows document changes related to git's HEAD</flag>
+ <flag name="terminal">Embed a terminal in the bottom pane</flag>
+</use>
+</pkgmetadata>