summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-editors/gedit-plugins
reinit the tree, so we can have metadata
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest5
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild97
-rw-r--r--app-editors/gedit-plugins/metadata.xml16
3 files changed, 118 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
new file mode 100644
index 000000000000..783a4e7b14b6
--- /dev/null
+++ b/app-editors/gedit-plugins/Manifest
@@ -0,0 +1,5 @@
+DIST gedit-plugins-3.22.0.tar.xz 1314512 SHA256 83a73088de73478841b9a216bd89c2e478aa302b3579a2a8685893d7a6a48fdc SHA512 5560b48c0b21b535de7247c39653c111439f9cb138025d7e3a600b94babbe060777c2095160b7e5ea39b8ba8be520ea3966b0ffc2ec15d17ea0bf814bf58748d WHIRLPOOL 81c9d266982377e43082a71a6ebbbff96f426912bd07b10e1000a70894982af71f6617e6e9bb27d932214509e622740ecf72af5929a0d4f5d4085052696cd954
+EBUILD gedit-plugins-3.22.0.ebuild 2418 SHA256 f1fbb512e7d23de85fe132c98d1593565deb261656f7166513ab79a74f7b36b3 SHA512 c281e7d554951875681f8a4592568006977d74c04cb60db0683766c634b09d8caff228125001f8bac8cb54b06e16a14a969ce6983e0acc9e1ec34832b02ba64e WHIRLPOOL 14619f59c37f81c419a4be390ddfd1d3c473fd7f6bf0fdb24375972f9144c2204a06c968cfdaae005d2b1989abb86eb87d27208d38d6a3d58c2869b6347b9212
+MISC ChangeLog 4942 SHA256 6133cc61ce4b51d171ccaae6abd0c24e6eee330f46d8ab43610d6a31e62653e8 SHA512 58828c19a7891e41f66fc50574c9774859059e2d9ea4de3b2359ba0988e4193f5566d6d1c1cb4c8ea27251103d0879ae3e818671d6e52ec60947567565184d90 WHIRLPOOL 6dec47a5f613cbd3ece427f86d2d9f46e45c90d30c823335adbc87c0584a617be78e7c2588f4889ddf4a170adc38385b7c12f09a3c89e546e69d33330e71689f
+MISC ChangeLog-2015 10767 SHA256 3ef9357a5c830dd9fe787999c8e43956ca259322eb01fd00afabcc844c3fbdb4 SHA512 579959c1e31382d0004d3eac2ca87306db46bdefe36dc145943a6b1090eba3671ef97cf88c77aa95d42a167d4a85f97390bd50633fa6248074da655b6eb18584 WHIRLPOOL 493a93a2602233fe65717294dbab5ce421ae8fdb0815aeaf658a9c65c0576762793aec7aa73ce4ded30922391fe41ac0c73af9613da9d280a0d240cd2ab67f96
+MISC metadata.xml 643 SHA256 9a348fe86587ab346256d1ea958ca9e1c49cea3b75e735eacf8c7328c427fbcf SHA512 e699d207fcc3d0c2f0fdeb6c3bb6d8db3f4afc4f17065d9ade43c257db59357a179ecd380cda15c46bf5342dd68fe80c6eba0707d912f04e469fd368ca1e40ef WHIRLPOOL e27135f168f343faff44794db1b8309dca3b3eb9e117c4d6eadf6e3e00f89a9d7502eeace9f415130cdf37a3650236cedae0983c1690c479759b43d7c0735280
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
new file mode 100644
index 000000000000..fdf3fe79fdaf
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{4,5} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit eutils gnome2 multilib python-single-r1 vala
+
+DESCRIPTION="Official plugins for gedit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="amd64 x86"
+SLOT="0"
+
+IUSE_plugins="charmap git terminal vala zeitgeist"
+IUSE="+python ${IUSE_plugins}"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+ zeitgeist? ( python )
+"
+
+RDEPEND="
+ >=app-editors/gedit-3.16
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libpeas-1.7.0[gtk]
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-3.21.3:3.0
+ python? (
+ ${PYTHON_DEPS}
+ >=app-editors/gedit-3.16[introspection,python,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-3.14:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6 )
+ terminal? ( x11-libs/vte:2.91[introspection] )
+ vala? ( $(vala_depend) )
+ zeitgeist? ( >=gnome-extra/zeitgeist-0.9.12[introspection] )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable vala) \
+ $(use_enable zeitgeist)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # FIXME: crazy !!!
+ if use python; then
+ find "${ED}"/usr/share/gedit -name "*.py*" -delete || die
+ find "${ED}"/usr/share/gedit -type d -empty -delete || die
+ fi
+
+ # FIXME: upstream made this automagic...
+ clean_plugin charmap
+ clean_plugin git
+ clean_plugin terminal
+}
+
+clean_plugin() {
+ if use !${1} ; then
+ rm -rf "${ED}"/usr/share/gedit/plugins/${1}*
+ rm -rf "${ED}"/usr/$(get_libdir)/gedit/plugins/${1}*
+ fi
+}
diff --git a/app-editors/gedit-plugins/metadata.xml b/app-editors/gedit-plugins/metadata.xml
new file mode 100644
index 000000000000..ef0c87055091
--- /dev/null
+++ b/app-editors/gedit-plugins/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<longdescription>Official plugins for gedit</longdescription>
+<use>
+ <flag name="charmap">Insert special characters just by clicking on
+ them</flag>
+ <flag name="git">Shows document changes related to git's HEAD</flag>
+ <flag name="terminal">Embed a terminal in the bottom pane</flag>
+ <flag name="zeitgeist">Build the plugin to inject events to <pkg>gnome-extra/zeitgeist</pkg></flag>
+</use>
+</pkgmetadata>