summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/gedit-plugins
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.36.2.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index f4c8195a9661..d0b5cc57157d 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-3.34.1.tar.xz 978800 BLAKE2B 03225ddc414e172f08179c64fbf12d0282c131b71855ca9dc20ceaa5750a5555c7bdde8c4ff1d95c721177b3d379edbcfc9af19ec22b96942df1913d13560303 SHA512 7fe31c2b0a1381a44362bd6066422d182b2246e3f903f8cd83cde0467b9853620a445bea7878d93e95a0a71ac5d5dd081a1930d602007cf2a6ef00b1a45bebfc
+DIST gedit-plugins-3.36.2.tar.xz 980648 BLAKE2B 37f55b742258b233d161ce808483ba10f158b951f06eaee53d966edc275dad67a2d11eae342fed7bc9b185d1309c5795f645eabf24db99a6e6551a3dae19ddb6 SHA512 d46a5ec69f69838144333ca3e66abc7c64cdb3248877b38298f869027dd3bab16102957e723ad1b0d3c6af55745c2b7ce321949acb2575734c649a388bb0100b
EBUILD gedit-plugins-3.34.1.ebuild 2750 BLAKE2B 31b530c4ab8fa64b5f7c847a514667e60f150533aa7b7ee3d74f157beead02fc11d984fcc8132ca95150cefe68c155524bd336afc2f1850019aa277ecfdbc6e2 SHA512 8af5c9214f9f020af53b87289f56dac82934db2c59623466a1e220d262596c441fdf859c3b4107f9c821665e6d3b177e1d98f54fffa88b34a7b2866130111243
+EBUILD gedit-plugins-3.36.2.ebuild 2725 BLAKE2B 377335c8a74465a5202b16766b962b243627fba7f7e89689d069c497292b8aefa97ebf84ba670a9d33989505d01dd14f1e33b0b4ba0b453adb3ea69268ab2b8c SHA512 1434c2e4a1f8771d3555bf699a0e3090d745fa0c69f47955f6a7bc959c304629de1524b504bc01b89cb3ee07eb536eef2bf0b9c99b197e63216374934ab9dab1
MISC metadata.xml 542 BLAKE2B 1336fdd161ef76bb2e1445dd074aed82e04be00c9c47885eb5005122c850193dd2bec1aed69dd1da74527c8ee82d7c75d57b73d020cc692e41f6762ba43d8f08 SHA512 1eba6ba724a313d8dd04e838c448cb8de2f3411b891daaacdea615f0d8187d3bbe1f650c9b2ab5457d519ed98dee600d8830e7eea848c872ccb9c52ba58f231a
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.36.2.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.36.2.ebuild
new file mode 100644
index 000000000000..44c04dbe3953
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.36.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-3.36
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-editors/gedit-3.36[introspection,python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ $(meson_use python plugin_commander)
+ -Dplugin_drawspaces=true
+ $(meson_use vala plugin_findinfiles)
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ $(meson_use python plugin_translate)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}