summaryrefslogtreecommitdiff
path: root/app-editors/featherpad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /app-editors/featherpad
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'app-editors/featherpad')
-rw-r--r--app-editors/featherpad/Manifest3
-rw-r--r--app-editors/featherpad/featherpad-1.5.0-r1.ebuild (renamed from app-editors/featherpad/featherpad-1.5.0.ebuild)2
-rw-r--r--app-editors/featherpad/featherpad-9999.ebuild32
3 files changed, 35 insertions, 2 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index d45a32c30c2a..2f91c1e13b95 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1,3 +1,4 @@
DIST featherpad-1.5.0.tar.gz 1087068 BLAKE2B aef468f426c9c635624fe16f8180647a9f62a12c98d654dfb340758ff524e629341469ec3f37cfe8a481def99ba6c99672aa31c49b03226e2e895dce11e9b5e6 SHA512 984d1fba0e4bcb1eda8c2dd3bee34cf2ee0ba5604dd2c9328cc67531099b8a806e8ab79020510049eb788764cf0ad4486c128eefb43d9ab1ccdc4a3c06c48497
-EBUILD featherpad-1.5.0.ebuild 738 BLAKE2B b92ac1f6804c858e495fdfd77789e983937d3d9155422f1542766557fdd55dd17d06e530d20f8bae2c36a5b00e62c8488c63759398c94184f5b95fb788e90c92 SHA512 4a75b3194556efb4e5fc5cd91deaca303b6ea0dfe283ef1c98467bbcce9a5723d19883e5aa09b80f04ea857259f579778c6ad2b4b5b3c77ed50034d034d9f4e5
+EBUILD featherpad-1.5.0-r1.ebuild 733 BLAKE2B f9540acb8dab4daa9e0faa58ce5670eaeadb47a47378ca1d36f38aeda1a3be9c1b413be6cb294e6fdf268b3b9b0b5075b3aa6ff5aa8f94920df0993e9af107e7 SHA512 b6dab2f8c247d564bdc9dffaaaa1145f47b64edc8145da539cc96f0265fbebcb1dc27720af7299661a7f716c76ca95e57b4d7c63f847a4041a717d34b21d108e
+EBUILD featherpad-9999.ebuild 623 BLAKE2B a067a835d4958f5263bd8ecc61cc11e2a0e0075a9c017a23bf95bdf5754d4243930b07951a459c064b7fe21730237187d6b42b489b5e77c2f5f32e88a1d993e8 SHA512 4a2ee2876d2e18adf34bd6c2d45f79d88a4892b984dce6711030e1fdb71d897d940646a656fc59aeac14d15d464d7e0d45dfe97d96540d30c235ceb3457fd612
MISC metadata.xml 940 BLAKE2B 7d24c11cd115ff1687eafc01966063fa7725918f03b9dfc6e0f55c32e99f78a2a0123cdf01b447c2c9defd5f9e92291a6a517f99ef1a6cb8ac533f0d5cdf3d6e SHA512 e405c9af3d902e48ef4db68513b79c4bf28d40a76f6fdb951cc3f1e311741b6fd46dad2c322c5d22aece2dc0ff4c46a5b4ce949c615881896b889604c3185e4a
diff --git a/app-editors/featherpad/featherpad-1.5.0.ebuild b/app-editors/featherpad/featherpad-1.5.0-r1.ebuild
index 229b5bbfe620..9b69e0fe90b1 100644
--- a/app-editors/featherpad/featherpad-1.5.0.ebuild
+++ b/app-editors/featherpad/featherpad-1.5.0-r1.ebuild
@@ -17,7 +17,7 @@ IUSE="+X"
RDEPEND="
app-text/hunspell:=
- dev-qt/qtbase:6[cups,dbus,gui,widgets]
+ dev-qt/qtbase:6[dbus,gui,widgets]
dev-qt/qtsvg:6
X? ( x11-libs/libX11 )
"
diff --git a/app-editors/featherpad/featherpad-9999.ebuild b/app-editors/featherpad/featherpad-9999.ebuild
new file mode 100644
index 000000000000..5ae9de86c8fd
--- /dev/null
+++ b/app-editors/featherpad/featherpad-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+EGIT_REPO_URI="https://github.com/tsujan/FeatherPad"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}