summaryrefslogtreecommitdiff
path: root/app-editors/fe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-editors/fe
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-editors/fe')
-rw-r--r--app-editors/fe/Manifest3
-rw-r--r--app-editors/fe/fe-2.0.ebuild11
-rw-r--r--app-editors/fe/files/fe-2.0-ar.patch21
3 files changed, 32 insertions, 3 deletions
diff --git a/app-editors/fe/Manifest b/app-editors/fe/Manifest
index ab34127f9227..337c014f11a2 100644
--- a/app-editors/fe/Manifest
+++ b/app-editors/fe/Manifest
@@ -1,4 +1,5 @@
AUX fe-1.8-makefile.patch 370 BLAKE2B f0bfc2c97e30ce35a904394a871b275043ee479392997117f1886cebf57fb1fe9f056fdb0bd94f4130837323fc2c20e94aeb575ad0d0f3a80af7199e2fbd3759 SHA512 09820543f98e166a9692788d0b42f29b6ee60852f0e6197af86b4b8da31c902ff9c8be59e925af21e50241d5ef6e629195190dda6a1d0317e601abb4135e1238
+AUX fe-2.0-ar.patch 502 BLAKE2B 4c3beea491ddb03a3adf5923c8fbdc0279ac9e6899216af71018af425f7caa33faa47ec6bc89b6a409d5370ffa0553fe9e7ca744a2ee238c36d2ceac378a1c3f SHA512 1c5ede0c9570f31ba3c42fd43f2c77170dce957a8376f02adaa2b82687e3daef9c8e0a941377de915be968d10e6fa34274b433eba396273cfe20ed1868dbd17b
DIST fe-2.0.tar.gz 217430 BLAKE2B bbc886abdb54d5fe05f031a5e5700907586c4bae8812f4edd5bf6d35fa0ce16edb93a6f988a597e1b4aba69bde4019f3044091ab9285ee6138d913498816453b SHA512 85afa800466376e59aa8de4af06db51c5df8566109a1f632b30a366f944be3237f88a639329d44114360747836ed75c31746c7d6bf1568b7b4ff3e11d595a6e7
-EBUILD fe-2.0.ebuild 784 BLAKE2B f4639eb6e54589ba2c6b3b6cac195859585d8b422eee73062f0bda9d95eb6ae340d6f35165a20c32402814b9fcb9c49678f6925658b8a252e6ada23a940b7ed0 SHA512 1f7dc3bdd3a7c04c3ee0bbb0f90dabfc0814edaee82e97cc3aacd5633337e5a42660b1ac45d03080af38bee522184f76731d91304d4b513301b9bb4be28403a1
+EBUILD fe-2.0.ebuild 859 BLAKE2B 600346c9cd0ea2ffa6795579dfb05eb5af3307e9e63531049b717db05fcd140136d0c8d005cb0fc388e24c24c55cfeb6992cf324b782a9177f137c44f88b5b9f SHA512 d09002589b3c4a279131ce179bdade3772971980ad9bad00d3b9023b49f1a34e237fd083bb1b76001bfaece4608c54cbe26b72e0a9147e922bf9f1289a44513b
MISC metadata.xml 1259 BLAKE2B e393bad45601c7e357aa4c4e5e6ede35cdd6758a1cc251cfc3acca0e8526ffb696c0ca484b312be14d23a05d8996ce7fb3bee37fe7a8c9bc72d5c507c26729df SHA512 6539d808d3cd85bab1985dbfb69ddbd01166a4e6dcf66d0f138d1ff1e52d9b7342ff3b468e031f9372308533296e28eb978b00954624890a897b5f41c222f701
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
index ca6658d94079..207e9ec3f773 100644
--- a/app-editors/fe/fe-2.0.ebuild
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,10 @@ RDEPEND="sys-libs/ncurses:0=
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8-makefile.patch
+ "${FILESDIR}"/${P}-ar.patch
+)
src_configure() {
econf \
@@ -27,6 +30,10 @@ src_configure() {
LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
emake \
prefix="${D}"/usr \
diff --git a/app-editors/fe/files/fe-2.0-ar.patch b/app-editors/fe/files/fe-2.0-ar.patch
new file mode 100644
index 000000000000..8096400ab01e
--- /dev/null
+++ b/app-editors/fe/files/fe-2.0-ar.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/722036
+
+--- fe-2.0-orig/Makefile.in
++++ fe-2.0/Makefile.in
+@@ -15,6 +15,7 @@
+ CPPFLAGS= @CPPFLAGS@ -DLOCALEDIR=\"$(localedir)\"
+ LDFLAGS= @LDFLAGS@
+ LIBS= @LIBS@
++AR= ar
+
+ CATALOGS= de.mo
+ OBJS= buffer.o complete.o display.o macro.o misc.o msgline.o
+@@ -27,7 +28,7 @@
+ $(CC) -o $@ $(LDFLAGS) fe.o libfe.a $(LIBS)
+
+ libfe.a: $(OBJS)
+- rm -f $@; ar q $@ $(OBJS); @RANLIB@ $@
++ rm -f $@; $(AR) q $@ $(OBJS); @RANLIB@ $@
+
+ install-po: install-po-@USE_NLS@
+ install-po-no: