summaryrefslogtreecommitdiff
path: root/app-editors/fe/fe-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-editors/fe/fe-2.0.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-editors/fe/fe-2.0.ebuild')
-rw-r--r--app-editors/fe/fe-2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
index 9e1866c107ce..ca6658d94079 100644
--- a/app-editors/fe/fe-2.0.ebuild
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A small and easy to use folding editor"
HOMEPAGE="http://www.moria.de/~michael/fe/"
SRC_URI="http://www.moria.de/~michael/fe/${P}.tar.gz"
@@ -15,11 +17,14 @@ IUSE="sendmail"
RDEPEND="sys-libs/ncurses:0=
sendmail? ( virtual/mta )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
src_configure() {
- econf $(use_enable sendmail)
+ econf \
+ $(use_enable sendmail) \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
src_install() {