summaryrefslogtreecommitdiff
path: root/app-editors/ersatz-emacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/ersatz-emacs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/ersatz-emacs')
-rw-r--r--app-editors/ersatz-emacs/Manifest4
-rw-r--r--app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild42
-rw-r--r--app-editors/ersatz-emacs/files/ersatz-emacs-20060515-gentoo.patch57
-rw-r--r--app-editors/ersatz-emacs/metadata.xml15
4 files changed, 118 insertions, 0 deletions
diff --git a/app-editors/ersatz-emacs/Manifest b/app-editors/ersatz-emacs/Manifest
new file mode 100644
index 000000000000..985ba333d8f7
--- /dev/null
+++ b/app-editors/ersatz-emacs/Manifest
@@ -0,0 +1,4 @@
+AUX ersatz-emacs-20060515-gentoo.patch 971 BLAKE2B 2730f247c341bb89e8f0c1eadb5730098091cd01a5b1ceaef76fdd516c2cdbfb532ce25312e0ab71ba404bfca83e6a30d90982842dcce13e45d70859c9862cae SHA512 dd9264a80f80eeb06a1c194d9f9df02c2b53fc143ec676e9c9489b57d337fe2b42240029026acc932f05b11ca78464033a5571990dca1cae716932d3c9a300fe
+DIST ersatz-emacs-20060515.tar.gz 45581 BLAKE2B 641cad2f5a873b0c70743a6f60ffc31615bb8789d5c6a100a67aaa82c59e7a83d35023eb596303ef0160e3ff561c89e5814b685a7a650aa4625326e86ec4fdf3 SHA512 c30ede63ebb44076762aa430a73c73d3fa3bcd0e3d0016162aab31347257124479f464a1003012f7418e807abfd3c613c81f5196ccf65b0cb3f939b7ad5c989d
+EBUILD ersatz-emacs-20060515.ebuild 998 BLAKE2B 8f2d0f17c67743b133976585a46c2bf759e84863d6be4e490aa8268d953b9a740b9ca3b763d9591c1cd238ab2a20efde978fcef837bcdeb6d43a0121ff983f78 SHA512 fb40ee9f53105526538b353bcbffa9f3c8b361f9da27289f127b6eff53f78f860577f633172e975338df6d781d85d6b629a4051cc2328bd0ba1a6f7e28099406
+MISC metadata.xml 610 BLAKE2B c7dc603c9e9ac838bd21b3e6f513f1e3f79370f9eedcc0f6973c812526c342408e1eac696d5b0c9fe3a5f8c20911af7f7bc9cc4260f443f2ec0cd80d60dbf724 SHA512 a48b4e5215cdd4a33802ef3fcf3324f43bd3c8ec8d70ba6be8e295c8dda35c4e4df400a04afbf4193c595c7dd4d23aeee38cb80585e498b1b77907aaedb56926
diff --git a/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild b/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild
new file mode 100644
index 000000000000..2b147efbad2e
--- /dev/null
+++ b/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A very minimal imitation of the famous GNU Emacs editor"
+HOMEPAGE="http://hunter.apana.org.au/~cjb/Code/"
+# taken from http://hunter.apana.org.au/~cjb/Code/ersatz.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="!app-editors/ee
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s%/usr/local/share/%/usr/share/doc/${PF}/%" ee.1 \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ # Note: /usr/bin/ee is "easy edit" on FreeBSD, so if this
+ # is ever keyworded *-fbsd the binary has to be renamed.
+ dobin ee
+ doman ee.1
+ dodoc ChangeLog ERSATZ.keys README
+}
diff --git a/app-editors/ersatz-emacs/files/ersatz-emacs-20060515-gentoo.patch b/app-editors/ersatz-emacs/files/ersatz-emacs-20060515-gentoo.patch
new file mode 100644
index 000000000000..67c40e789241
--- /dev/null
+++ b/app-editors/ersatz-emacs/files/ersatz-emacs-20060515-gentoo.patch
@@ -0,0 +1,57 @@
+--- display.c
++++ display.c
+@@ -5,6 +5,7 @@
+ * hints that are left in the windows by the commands
+ */
+
++#include <stdlib.h>
+ #include <string.h>
+ #include "estruct.h"
+ #include "edef.h"
+@@ -100,7 +101,6 @@
+ void vtinit ()
+ {
+ VIDEO *vp;
+- char *malloc ();
+ int i;
+
+ (*term.t_open) ();
+--- line.c
++++ line.c
+@@ -47,7 +47,6 @@
+ {
+ LINE *lp;
+ int size;
+- char *malloc ();
+
+ size = (used + NBLOCK - 1) & ~(NBLOCK - 1);
+ if (size == 0) /* Assume that an empty */
+@@ -469,8 +468,6 @@
+ */
+ int kinsert (int c)
+ {
+- char *realloc ();
+- char *malloc ();
+ char *nbufp;
+
+ if (kused == ksize)
+--- tcap.c
++++ tcap.c
+@@ -2,6 +2,7 @@
+
+ #define termdef 1 /* don't define "term" external */
+
++#include <stdlib.h>
+ #include <stdio.h> /* puts(3), snprintf(3) */
+ #include "estruct.h"
+ #include "edef.h"
+--- termio.c
++++ termio.c
+@@ -5,6 +5,7 @@
+ */
+
+ #undef CTRL
++#include <stdlib.h>
+ #include <termios.h>
+ #include <unistd.h>
+ #include <signal.h>
diff --git a/app-editors/ersatz-emacs/metadata.xml b/app-editors/ersatz-emacs/metadata.xml
new file mode 100644
index 000000000000..047063ba435e
--- /dev/null
+++ b/app-editors/ersatz-emacs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ Ersatz Emacs is a very minimal imitation of the famous GNU Emacs editor.
+ Unlike most popular Emacs derivatives, Ersatz strives to use as little
+ system resources as possible and be simple enough for the casual programmer
+ to understand, yet still include all the functionality required for most
+ text editing jobs.
+</longdescription>
+</pkgmetadata>