summaryrefslogtreecommitdiff
path: root/app-editors/emact
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/emact
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/emact')
-rw-r--r--app-editors/emact/Manifest5
-rw-r--r--app-editors/emact/emact-2.56.0.ebuild31
-rw-r--r--app-editors/emact/emact-2.58.0.ebuild27
-rw-r--r--app-editors/emact/metadata.xml27
4 files changed, 90 insertions, 0 deletions
diff --git a/app-editors/emact/Manifest b/app-editors/emact/Manifest
new file mode 100644
index 000000000000..a21237fe622a
--- /dev/null
+++ b/app-editors/emact/Manifest
@@ -0,0 +1,5 @@
+DIST emact-2.56.0.tar.gz 578640 BLAKE2B 2bdf0a88003c0cbd28153737eac588dbb068ed99a1166dc66a5fac33f91d2b3c7e058518733c6eddbfeb3291f3ad89dd4a6bfc4b11ccda0963a314a5fbf4e2b0 SHA512 96fce3bf3e00e84abd9de0778a02cfd284689073391e6f9eb3bb4a54e8899ae32d9e8acd45d0f1d575e36f171ca148fc574c9ecc71615df9a9907ee1d30bb99d
+DIST emact-2.58.0.tar.gz 581248 BLAKE2B 9be43cfc37973d683c5c824bf2f2d60d0ffab2791c46a4082f04d83fc705713d5806608e5802e786be4ced4b008842c5c6dca60b7a30c5483b29736ccc21ffe5 SHA512 43108d0bc1989ba6e11f12e86ad5fa4e0b06dc2cc11f54a8b1ca548bb91d2d201f62ffda5e8c11ff75a724229ca1a2ae3e2f439ebc62e1fe3f484f811a88a2c2
+EBUILD emact-2.56.0.ebuild 605 BLAKE2B aaff4cc4d961a4886aed31adc6a367783b344aba442c569ac4e573e3fdcbb71db1caf08d2f6a2d02993db42ca8e86fc6fc0494a20b995abf78d604c2fb990aac SHA512 c1b0ba7d6eafe7e177e412eb7310aff4ca2244c28099e05d38ec668346d3e518cd79b271e9204cfcbe0e9d654a2302105c8288a7b9eacfa4fde395c11737874b
+EBUILD emact-2.58.0.ebuild 535 BLAKE2B aad06c8aa38848e686baf904753ad0c69dc845bba57ef6d14c879994c304e066c022c4efe8cd62a2bef2ddc52ac627e21a66f7f3d0bbb90dab2c6a4f486d62a4 SHA512 2825597c48b337f3a1a22c8f085203018f288805006177f054d94339394b0af1370129fb6e7aa31775e60b29032f52374541ae0d6bf5420fec5e4e0572687a15
+MISC metadata.xml 1356 BLAKE2B 6038a2811fe4103bcba606fe464c1ca1ddf0765f064507d84aaeaf92f92de0c51ca4d75a88a32576a50631f694ad2e84d842602c50f03a2e9ac9ee4b8a0a12e4 SHA512 f376c46dc531f259dda9842b817c5eb040c4c2f9ee811e728770b660e4af1b8d588081e34bd3149c88fbbfbb976cc6cdb3013a8c8a5ae488a198a9c3ac10d75d
diff --git a/app-editors/emact/emact-2.56.0.ebuild b/app-editors/emact/emact-2.56.0.ebuild
new file mode 100644
index 000000000000..5ac2733b21f4
--- /dev/null
+++ b/app-editors/emact/emact-2.56.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # files in the tarball have all mode bits set to zero ...
+ chmod +x configure || die
+}
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ #dodoc README
+}
diff --git a/app-editors/emact/emact-2.58.0.ebuild b/app-editors/emact/emact-2.58.0.ebuild
new file mode 100644
index 000000000000..6e0ffca331b0
--- /dev/null
+++ b/app-editors/emact/emact-2.58.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake INSTALL="${ED%/}"/usr install
+ #dodoc README
+}
diff --git a/app-editors/emact/metadata.xml b/app-editors/emact/metadata.xml
new file mode 100644
index 000000000000..d94e6b286818
--- /dev/null
+++ b/app-editors/emact/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ This product is an original development made to provide an emacs-like editor
+ on the PC for the purpose of writing Lisp code with the same features found
+ on other Lisp development systems. In 1985, with about 512 Ko of memory, it
+ was obvious that Gosling, GNU or other emacs written in Lisp were too big to
+ run on M$-DOG. So I decided to write my own editor that closely works like
+ those I used on VAX Unix at that time. I started with Conroy's MicroEMACS.
+
+ After a great amount of time, made essentially after hours, EmACT is now
+ a pretty good clone of GNU Emacs. It has all the features that programmers
+ enjoy, like parentheses matching, auto-indent for Lisp, C, C++, compile
+ mode, tags and even a Lisp interpreter which is not however compatible with
+ GNU MockLisp. It can be ported to all UN*X systems (terminal and X-Window)
+ and it runs of course on all Intel based system in text or graphic mode
+ (MSDOS, OS/2, Windows 3.x, Windows NT/2000/XP and Windows 95/98/Me).
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">emact</remote-id>
+</upstream>
+</pkgmetadata>