summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-30.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-14 16:01:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-14 16:01:32 +0100
commit153fd195574cc30040446316bb666af0e58d985f (patch)
tree657cdfb683dfabd52ff06cb67ddd31b653fb9f43 /app-editors/emacs/emacs-30.0.9999.ebuild
parent3fa8418e7778f51be61ca1c9114059c73a477459 (diff)
gentoo auto-resync : 14:05:2023 - 16:01:32
Diffstat (limited to 'app-editors/emacs/emacs-30.0.9999.ebuild')
-rw-r--r--app-editors/emacs/emacs-30.0.9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-editors/emacs/emacs-30.0.9999.ebuild b/app-editors/emacs/emacs-30.0.9999.ebuild
index 6b5a455c09ea..1bb789044d24 100644
--- a/app-editors/emacs/emacs-30.0.9999.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools elisp-common readme.gentoo-r1 toolchain-funcs
+inherit autotools elisp-common flag-o-matic readme.gentoo-r1 toolchain-funcs
if [[ ${PV##*.} = 9999 ]]; then
inherit git-r3
@@ -40,7 +40,7 @@ DESCRIPTION="The extensible, customizable, self-documenting real-time display ed
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source sqlite ssl svg systemd +threads tiff toolkit-scroll-bars tree-sitter webp wide-int +X Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source sqlite ssl svg systemd +threads tiff toolkit-scroll-bars tree-sitter valgrind webp wide-int +X Xaw3d xft +xpm xwidgets zlib"
X_DEPEND="x11-libs/libICE
x11-libs/libSM
@@ -116,6 +116,7 @@ RDEPEND="app-emacs/emacs-common[games?,gui(-)?]
ssl? ( net-libs/gnutls:0= )
systemd? ( sys-apps/systemd )
tree-sitter? ( dev-libs/tree-sitter )
+ valgrind? ( dev-util/valgrind )
zlib? ( sys-libs/zlib )
gui? (
gif? ( media-libs/giflib:0= )
@@ -369,6 +370,9 @@ src_configure() {
}
src_compile() {
+ export ac_cv_header_valgrind_valgrind_h=$(usex valgrind)
+ append-cppflags -DUSE_VALGRIND=$(usex valgrind)
+
if tc-is-cross-compiler; then
# Build native tools for compiling lisp etc.
emake -C "${S}-build" src