summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-29.1.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 01:53:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 01:53:56 +0000
commit9f4b8d7fbdb3e35f8854c2e1c63926e383d299ea (patch)
treefe6bc16c271fcb3387f3243f0fb6f829b98b75fb /app-editors/emacs/emacs-29.1.9999.ebuild
parentfe3d938433735c9b681b7e72296a5ae70fd2a7e9 (diff)
gentoo auto-resync : 22:12:2023 - 01:53:56
Diffstat (limited to 'app-editors/emacs/emacs-29.1.9999.ebuild')
-rw-r--r--app-editors/emacs/emacs-29.1.9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/emacs/emacs-29.1.9999.ebuild b/app-editors/emacs/emacs-29.1.9999.ebuild
index 8a58f10bc90e..f5d1a6e3a2cc 100644
--- a/app-editors/emacs/emacs-29.1.9999.ebuild
+++ b/app-editors/emacs/emacs-29.1.9999.ebuild
@@ -210,11 +210,6 @@ src_prepare() {
sed -i -e 's/(executable-find "bwrap")/nil/' test/src/emacs-tests.el \
test/lisp/emacs-lisp/bytecomp-tests.el || die
- # Tests use this dir as GNUPGHOME. Move to shorter path, in order
- # not to exceed the 108 char limit for GnuPG's sockets on Linux.
- mv test/lisp/gnus/mml-sec-resources "${T}"/gnupg || die
- ln -s "${T}"/gnupg test/lisp/gnus/mml-sec-resources || die
-
AT_M4DIR=m4 eautoreconf
}
@@ -439,6 +434,15 @@ src_test() {
)
use xpm || exclude_tests+=( %src/image-tests.el )
+ # Redirect GnuPG's sockets, in order not to exceed the 108 char limit
+ # for socket paths on Linux.
+ mkdir "${T}"/gnupg || die
+ local f
+ for f in S.gpg-agent{,.browser,.extra,.ssh}; do
+ printf "%%Assuan%%\nsocket=%s\n" "${T}/gnupg/${f}" \
+ > "test/lisp/gnus/mml-sec-resources/${f}" || die
+ done
+
# See test/README for possible options
emake \
EMACS_TEST_VERBOSE=1 \