summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-26.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-editors/emacs/emacs-26.3-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-editors/emacs/emacs-26.3-r1.ebuild')
-rw-r--r--app-editors/emacs/emacs-26.3-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/emacs/emacs-26.3-r1.ebuild b/app-editors/emacs/emacs-26.3-r1.ebuild
index a9f8c3660f2c..7ec3305f06fb 100644
--- a/app-editors/emacs/emacs-26.3-r1.ebuild
+++ b/app-editors/emacs/emacs-26.3-r1.ebuild
@@ -104,8 +104,8 @@ BDEPEND="virtual/pkgconfig
RDEPEND="${RDEPEND}
!<app-editors/emacs-vcs-${PV}"
-EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"
-SITEFILE="20${PN}-${SLOT}-gentoo.el"
+EMACS_SUFFIX="emacs-${SLOT}"
+SITEFILE="20${EMACS_SUFFIX}-gentoo.el"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
@@ -309,7 +309,7 @@ src_install () {
sed -e "${cdir:+#}/^Y/d" -e "s/^[XY]//" >"${T}/${SITEFILE}" <<-EOF || die
X
- ;;; ${PN}-${SLOT} site-lisp configuration
+ ;;; ${EMACS_SUFFIX} site-lisp configuration
X
(when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
Y (setq find-function-C-source-directory
@@ -331,9 +331,9 @@ src_install () {
if use aqua; then
dodir /Applications/Gentoo
- rm -rf "${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app
+ rm -rf "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app
mv nextstep/Emacs.app \
- "${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app || die
+ "${ED}"/Applications/Gentoo/${EMACS_SUFFIX^}.app || die
fi
DOC_CONTENTS="You can set the version to be started by /usr/bin/emacs
@@ -348,7 +348,7 @@ src_install () {
machine would satisfy basic Emacs requirements under X11.
See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
for how to enable anti-aliased fonts."
- use aqua && DOC_CONTENTS+="\\n\\nEmacs${EMACS_SUFFIX#emacs}.app is in
+ use aqua && DOC_CONTENTS+="\\n\\n${EMACS_SUFFIX^}.app is in
\"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
it into /Applications by yourself."
readme.gentoo_create_doc