summaryrefslogtreecommitdiff
path: root/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index dc1e3f47c0a1..8b8852bab94b 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -260,6 +260,7 @@ src_configure() {
--without-compress-install \
--without-hesiod \
--without-pop \
+ --with-dumping=pdumper \
--with-file-notification=$(usev inotify || usev gfile || echo no) \
$(use_enable acl) \
$(use_with dbus) \
@@ -281,10 +282,10 @@ src_configure() {
${myconf}
}
-src_compile() {
- # Disable sandbox when dumping. For the unbelievers, see bug #131505
- emake RUN_TEMACS="SANDBOX_ON=0 LD_PRELOAD= env ./temacs"
-}
+#src_compile() {
+# # Disable sandbox when dumping. For the unbelievers, see bug #131505
+# emake RUN_TEMACS="SANDBOX_ON=0 LD_PRELOAD= env ./temacs"
+#}
src_install () {
emake DESTDIR="${D}" NO_BIN_LINK=t install
@@ -346,9 +347,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))
@@ -386,18 +387,8 @@ src_install () {
pkg_preinst() {
# move Info dir file to correct name
- local infodir=/usr/share/info/${EMACS_SUFFIX} f
- if [[ -f ${ED}${infodir}/dir.orig ]]; then
- mv "${ED}"${infodir}/dir{.orig,} || die
- elif [[ -d "${ED}"${infodir} ]]; then
- # this should not happen in EAPI 4
- ewarn "Regenerating Info directory index in ${infodir} ..."
- rm -f "${ED}"${infodir}/dir{,.*}
- for f in "${ED}"${infodir}/*; do
- if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
- install-info --info-dir="${ED}"${infodir} "${f}" || die
- fi
- done
+ if [[ -d ${ED}/usr/share/info ]]; then
+ mv "${ED}"/usr/share/info/${EMACS_SUFFIX}/dir{.orig,} || die
fi
}