summaryrefslogtreecommitdiff
path: root/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index ee8f5f2ac3c2..2862235ef56e 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -28,7 +28,7 @@ HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="27"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gzip-el imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
REQUIRED_USE="?? ( aqua X )"
RESTRICT="test"
@@ -38,6 +38,7 @@ RDEPEND="sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
dbus? ( sys-apps/dbus )
+ gmp? ( dev-libs/gmp:0= )
gpm? ( sys-libs/gpm )
!inotify? ( gfile? ( >=dev-libs/glib-2.28.6 ) )
json? ( dev-libs/jansson )
@@ -81,14 +82,13 @@ RDEPEND="sys-libs/ncurses:0=
)
)
gtk? (
- xwidgets? (
- net-libs/webkit-gtk:4=
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? (
x11-libs/gtk+:3
- x11-libs/libXcomposite
- )
- !xwidgets? (
- gtk3? ( x11-libs/gtk+:3 )
- !gtk3? ( x11-libs/gtk+:2 )
+ xwidgets? (
+ net-libs/webkit-gtk:4=
+ x11-libs/libXcomposite
+ )
)
)
!gtk? (
@@ -174,6 +174,7 @@ src_configure() {
if use X; then
myconf+=" --with-x --without-ns"
myconf+=" $(use_with gconf)"
+ myconf+=" $(use_with gmp libgmp)"
myconf+=" $(use_with gsettings)"
myconf+=" $(use_with toolkit-scroll-bars)"
myconf+=" $(use_with gif)"
@@ -211,11 +212,12 @@ src_configure() {
recommended that you compile Emacs with the Athena/Lucid or the
Motif toolkit instead.
EOF
- if use xwidgets; then
- myconf+=" --with-x-toolkit=gtk3 --with-xwidgets"
+ if use gtk2; then
+ myconf+=" --with-x-toolkit=gtk2 --without-xwidgets"
+ use xwidgets && ewarn \
+ "USE flag \"xwidgets\" has no effect if \"gtk2\" is set."
else
- myconf+=" --with-x-toolkit=$(usex gtk3 gtk3 gtk2)"
- myconf+=" --without-xwidgets"
+ myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
fi
for f in motif Xaw3d athena; do
use ${f} && ewarn \
@@ -235,8 +237,12 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf+=" --with-x-toolkit=no"
fi
- ! use gtk && use xwidgets && ewarn \
- "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+ if ! use gtk; then
+ use gtk2 && ewarn \
+ "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+ use xwidgets && ewarn \
+ "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+ fi
elif use aqua; then
einfo "Configuring to build with Nextstep (Cocoa) support"
myconf+=" --with-ns --disable-ns-self-contained"