summaryrefslogtreecommitdiff
path: root/app-editors/ee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/ee
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/ee')
-rw-r--r--app-editors/ee/Manifest6
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild52
-rw-r--r--app-editors/ee/files/ee-Wformat-security.patch28
-rw-r--r--app-editors/ee/files/ee-init-location.patch40
-rw-r--r--app-editors/ee/files/ee-signal.patch11
-rw-r--r--app-editors/ee/metadata.xml7
6 files changed, 144 insertions, 0 deletions
diff --git a/app-editors/ee/Manifest b/app-editors/ee/Manifest
new file mode 100644
index 000000000000..c4e3dbe166d1
--- /dev/null
+++ b/app-editors/ee/Manifest
@@ -0,0 +1,6 @@
+AUX ee-Wformat-security.patch 675 BLAKE2B 2fc022761f61081616565ab2161094aa40b6b13345063ddc59621878dd35153b24bc3bedc03cf7187d48434c34b331c6201c3577dce96d10983c3c4e3102aff2 SHA512 d6b8dc118c3381da71ea7d10673af52d8d36575480a274d5e0f30645e86b082d5381ee7682fcf9b253b621ba9138a350b132875ecdc9b2fb5ed75bd111ce5304
+AUX ee-init-location.patch 1280 BLAKE2B ad20c44a30c9b817af997966d191640860def4a7f1dd63678f4befc8390ce22f254d802b4c75998ad874551ef90aff727273b6abde60f28f92412a9ce6507cbc SHA512 69732f151f7d8e9779c6826c89e92e9e4b5a8ab1580b8de562897a322e61514e3225eaecb9e2bf9fdf7063a126382ea9ba9ff7c233b2bebd8d4062b61b20375a
+AUX ee-signal.patch 222 BLAKE2B a514c6d060fde8c71d7a0dbb22d1d6843c9195500e5b675cda79645785a965f20144d26e558daf4f2acb6dd81d735ee4929991ea40d7bf88e091769951b20830 SHA512 9ce2f028d131b2ca47070002603b40c6841e8c69448cf419128cbf9519df928249de0fa7d1c9e906ea2a0368e8b6f9603ab26e8d0d352cc647e2ca9c5a93213c
+DIST ee-1.5.2.src.tgz 69651 BLAKE2B 2d79b889ad5c97d4f2e134acec235f8f1dfbf0c697936de326be448e0bb193f06cbaeadf5a99050fc47f0526bbeb571522513f363695190c1801c62aee1594f2 SHA512 9ca0e82d65971b0bce38e09c365b6eb8b81ca6ff5b244107ae254322e47e841e7f5345bf242a0a9dd66b731d46cead6f442016b9e070a1298e1a5319b1d7b97a
+EBUILD ee-1.5.2.ebuild 1127 BLAKE2B d4071be3623f1790e3e0c68672bfd16526f4e0809cc16b3e10ab4e8980a662c93c9601aa7d338c49ec4de9e68f6323f87743bbfd2d199472e7c628ecfcdefe33 SHA512 b1d70ea533e12104f926d7cd8320a86f11bbc5fa5b066c1512d977b8b8111f7e644231d41f1213a8aa3845bfa4a8548b872e575c590384a47867f29bdc657b3e
+MISC metadata.xml 221 BLAKE2B 6fb71e3c82061054a0c2d88c1ce8e591d5742628fe53032c9efd2c371ce1e8b0135b00ac91fa1905df39a507d5faa5871fb3a30d167dd46cec581682ba17c8ff SHA512 a11e9bbbabc9ac96985c5dc247e601b065fa762f12bce74224896c27aee34eb908187622bfc849c39c6c722a8ef8ee72b248afc84da1b0eb72f1ff5eeb13bbf0
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
new file mode 100644
index 000000000000..fc1aec479af4
--- /dev/null
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy to use text editor. A subset of aee"
+#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.src.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="!app-editors/ersatz-emacs"
+S="${WORKDIR}/easyedit-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-init-location.patch
+ "${FILESDIR}"/${PN}-signal.patch
+ "${FILESDIR}"/${PN}-Wformat-security.patch
+)
+DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
+
+src_prepare() {
+ sed -i \
+ -e "s/make -/\$(MAKE) -/g" \
+ -e "/^buildee/s/$/ localmake/" \
+ Makefile
+
+ sed -i \
+ -e "s/\tcc /\t\\\\\$(CC) /" \
+ -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
+ -e "/other_cflag/s/ *-s//" \
+ create.make
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+ keepdir /usr/share/${PN}
+}
diff --git a/app-editors/ee/files/ee-Wformat-security.patch b/app-editors/ee/files/ee-Wformat-security.patch
new file mode 100644
index 000000000000..6db64188347a
--- /dev/null
+++ b/app-editors/ee/files/ee-Wformat-security.patch
@@ -0,0 +1,28 @@
+--- a/ee.c
++++ b/ee.c
+@@ -2105,11 +2105,11 @@
+ }
+ else if (!strcmp("-?", buff))
+ {
+- fprintf(stderr, usage0, arguments[0]);
+- fprintf(stderr, usage1);
+- fprintf(stderr, usage2);
+- fprintf(stderr, usage3);
+- fprintf(stderr, usage4);
++ fprintf(stderr, "%s", usage0, arguments[0]);
++ fprintf(stderr, "%s", usage1);
++ fprintf(stderr, "%s", usage2);
++ fprintf(stderr, "%s", usage3);
++ fprintf(stderr, "%s", usage4);
+ exit(1);
+ }
+ else if ((*buff == '+') && (start_at_line == NULL))
+@@ -3243,7 +3243,7 @@
+ }
+ if (shell_fork)
+ {
+- printf(continue_msg);
++ printf("%s", continue_msg);
+ fflush(stdout);
+ while ((in = getchar()) != '\n')
+ ;
diff --git a/app-editors/ee/files/ee-init-location.patch b/app-editors/ee/files/ee-init-location.patch
new file mode 100644
index 000000000000..5ac1e47ae962
--- /dev/null
+++ b/app-editors/ee/files/ee-init-location.patch
@@ -0,0 +1,40 @@
+--- a/ee.1
++++ b/ee.1
+@@ -406,7 +406,7 @@
+ .PP
+ Since different users have different preferences, \fIee\fR allows some
+ slight configurability. There are three possible locations for an
+-initialization file for ee: the file \fI/usr/local/lib/init.ee\fR, the
++initialization file for ee: the file \fI/usr/share/ee/init.ee\fR, the
+ file \fI.init.ee\fR in the user's home directory, or the file \fI.init.ee\fR
+ in the current directory (if different from the home
+ directory). This allows system administrators to set some preferences for
+@@ -414,7 +414,7 @@
+ and the user to customize settings for particular directories (like one
+ for correspondence, and a different directory for programming).
+ .PP
+-The file \fI\/usr/local/lib/init.ee\fR is read first, then
++The file \fI\/usr/share/ee/init.ee\fR is read first, then
+ \fI$HOME/.init.ee\fR, then \fI.init.ee\fR, with the settings specified by the
+ most recent file read taking precedence.
+ .PP
+@@ -521,7 +521,7 @@
+ may be too slow for slower systems.
+ .SH FILES
+ .PP
+-.I /usr/local/lib/init.ee
++.I /usr/share/ee/init.ee
+ .br
+ .I $HOME/.init.ee
+ .br
+--- a/ee.c
++++ b/ee.c
+@@ -4124,7 +4124,7 @@
+ }
+
+ unsigned char *init_name[3] = {
+- "/usr/local/lib/init.ee",
++ "/usr/share/ee/init.ee",
+ NULL,
+ ".init.ee"
+ };
diff --git a/app-editors/ee/files/ee-signal.patch b/app-editors/ee/files/ee-signal.patch
new file mode 100644
index 000000000000..41cfa4013068
--- /dev/null
+++ b/app-editors/ee/files/ee-signal.patch
@@ -0,0 +1,11 @@
+--- a/ee.c
++++ b/ee.c
+@@ -552,7 +552,7 @@
+ {
+ int counter;
+
+- for (counter = 1; counter < SIGUNUSED; counter++)
++ for (counter = 1; counter < SIGSYS; counter++)
+ signal(counter, SIG_IGN);
+
+ signal(SIGCHLD, SIG_DFL);
diff --git a/app-editors/ee/metadata.xml b/app-editors/ee/metadata.xml
new file mode 100644
index 000000000000..21dc8fdf43ff
--- /dev/null
+++ b/app-editors/ee/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>