summaryrefslogtreecommitdiff
path: root/app-editors/dav/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-editors/dav/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-editors/dav/files')
-rw-r--r--app-editors/dav/files/dav-0.8.5-asneeded.patch5
-rw-r--r--app-editors/dav/files/dav-0.8.5-davrc-buffer-overflow.patch4
-rw-r--r--app-editors/dav/files/dav-0.8.5-fno-common.patch24
-rw-r--r--app-editors/dav/files/dav-0.8.5-makefile.patch21
4 files changed, 49 insertions, 5 deletions
diff --git a/app-editors/dav/files/dav-0.8.5-asneeded.patch b/app-editors/dav/files/dav-0.8.5-asneeded.patch
index 75a43c67f43d..92bc6ebfdacc 100644
--- a/app-editors/dav/files/dav-0.8.5-asneeded.patch
+++ b/app-editors/dav/files/dav-0.8.5-asneeded.patch
@@ -1,6 +1,5 @@
-diff -u -r a/Makefile b/Makefile
---- a/Makefile 2004-02-22 02:04:07.000000000 +0100
-+++ b/Makefile 2008-12-30 19:31:19.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -12,7 +12,7 @@
LDFLAGS=-lncurses -O3 -Wall
diff --git a/app-editors/dav/files/dav-0.8.5-davrc-buffer-overflow.patch b/app-editors/dav/files/dav-0.8.5-davrc-buffer-overflow.patch
index a32e78ebc818..7287d36cc604 100644
--- a/app-editors/dav/files/dav-0.8.5-davrc-buffer-overflow.patch
+++ b/app-editors/dav/files/dav-0.8.5-davrc-buffer-overflow.patch
@@ -1,5 +1,5 @@
---- dav-0.8.5.orig/main.c 2011-01-29 14:16:53.537725568 -0500
-+++ dav-0.8.5/main.c 2011-01-29 14:20:45.139125094 -0500
+--- a/main.c
++++ b/main.c
@@ -327,7 +327,7 @@
void loadSettings()
{
diff --git a/app-editors/dav/files/dav-0.8.5-fno-common.patch b/app-editors/dav/files/dav-0.8.5-fno-common.patch
new file mode 100644
index 000000000000..df58fa36098d
--- /dev/null
+++ b/app-editors/dav/files/dav-0.8.5-fno-common.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/706846
+https://sources.debian.org/patches/dav-text/0.9.0-2/gcc-10.patch/
+--- a/main.c
++++ b/main.c
+@@ -58,7 +58,7 @@ char displayWholeScreen = 0;
+ struct buffer *buffers;
+ struct buffer *currentBuffer;
+ int currentBufferNum = 0;
+-
++ptrToFunction Fn_ptr[12]; //Bindings for the Fn keys; Fx = Fn_ptr[x-1]
+
+ int main(int argc, char *argv[])
+ {
+--- dav-text-0.9.0.orig/main.h
++++ dav-text-0.9.0/main.h
+@@ -47,7 +47,7 @@ void connectLines(struct line *baseline)
+ void determineLineNum(struct position *p);
+ void countTabs(struct line *l);
+ void determineCursX(struct position *p);
+-ptrToFunction Fn_ptr[12]; //Bindings for the Fn keys; Fx = Fn_ptr[x-1]
++extern ptrToFunction Fn_ptr[12]; //Bindings for the Fn keys; Fx = Fn_ptr[x-1]
+
+ extern int maxY,maxX;
+ extern int helpBarUpdate;
diff --git a/app-editors/dav/files/dav-0.8.5-makefile.patch b/app-editors/dav/files/dav-0.8.5-makefile.patch
new file mode 100644
index 000000000000..8ff62de305ee
--- /dev/null
+++ b/app-editors/dav/files/dav-0.8.5-makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 8b1ff0a..7a57840 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CC=gcc
++CC?=gcc
+ OBJECTS=main.o \
+ buffers.o \
+ fileIO.o \
+@@ -8,8 +8,8 @@ OBJECTS=main.o \
+ undo.o \
+ move.o
+
+-CFLAGS=-O3 -Wall
+-LDFLAGS=-lncurses -O3 -Wall
++CFLAGS?=O3 -Wall
++LDFLAGS?=lncurses -O3 -Wall
+
+ dav: $(OBJECTS)
+ $(CC) $(OBJECTS) $(LDFLAGS) -o dav