summaryrefslogtreecommitdiff
path: root/app-editors/curses-hexedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-editors/curses-hexedit
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-editors/curses-hexedit')
-rw-r--r--app-editors/curses-hexedit/Manifest2
-rw-r--r--app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild37
-rw-r--r--app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch53
3 files changed, 92 insertions, 0 deletions
diff --git a/app-editors/curses-hexedit/Manifest b/app-editors/curses-hexedit/Manifest
index 4eb5683967d2..5e490a9a9465 100644
--- a/app-editors/curses-hexedit/Manifest
+++ b/app-editors/curses-hexedit/Manifest
@@ -1,4 +1,6 @@
+AUX curses-hexedit-0.9.7-fno-common.patch 1077 BLAKE2B b9e43f69e84870e295ecb4bd9bfdcfb7cf5afe8cc6d432b0fc93acf5a837a566e7fd024ee74ff1f0e6abed8926b28e6dc5979a9d02f7690069eba84490cc6741 SHA512 868d8196406d89bb63e64887a0d13eacfe6ed1ad1faae63b460f5d6c996dbcd3d58c12430cef8177a5890be91f2940a21f1b69418d3aed9957a009e13e928c1c
AUX curses-hexedit-0.9.7-ncurses-pkg-config.patch 964 BLAKE2B aa433c31a1838cd9fd5d179f628aa2f4c9ffa44bc9eecd1c52c03b6b7a1837235259ad9c689bc6b574c56b0181c1a8ee556c46064b49b70a7393ce9ed99cbef1 SHA512 33efc29f64b9556e761f84d425b1e3c6207c06ecdac0499c9ce4fc1fe9023dbb06245987e8d4f23a6149607d033d1b6a22bf2e7cb5904f83a258cf0e91e56cda
DIST hexedit-0.9.7.tar.gz 165110 BLAKE2B 8adcb2aa8265ef01c475fcefc97c987da26107871ac87e6154b13257cf30283d5be96fb87d67b6b24d79cf0fdcca7c2bfcd1ef642e9bc1655141cada27fd9aab SHA512 b11b28538900f6e66a9efcca14cd8c2a312c29cea98c6ea5018cd3423e12876a9a4d0bf6dc4f94e7cb02e8bc8d3a406e6bccca7fa7dcbab2e4b717ee2fd826da
+EBUILD curses-hexedit-0.9.7-r1.ebuild 763 BLAKE2B 48ea365c5e427dbc40dae21a1ecbda03e4a44de239b077862f1b5010ca07fc4ca224caec119d454c8f2109ee37f61064ca9f141acacbc488ff91e44bd7901167 SHA512 01d4b6441532ba15a0068fe67a703d4a6f010cecf1f0e2dc0641bdd12a06db1a32bd927a80391cc8ecc6900f063600cccd472dfedcfb319998ee23c041f04e8a
EBUILD curses-hexedit-0.9.7.ebuild 726 BLAKE2B 683d121d255e5e4c8ffb1a0325dae1ee9354c6126c2db79c90e13af0c3b0cd71ef8908f777cf95a8ba619f2ec1425d58a2f738ae504b47d38bbf7b983098635e SHA512 7f4631bacfdb9c2a3a3f8910c27caee77ab087de74a585c7527fd72d779700493bb73cb19eb8979dd3727394dfd2c73c36d50853f7c5587cdf36a11b3ac7356f
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild b/app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..f274d12b8a5b
--- /dev/null
+++ b/app-editors/curses-hexedit/curses-hexedit-0.9.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# There's already a "hexedit" package in the tree, so name this one differently
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+MY_P=${P/curses-}
+DESCRIPTION="full screen curses hex editor (with insert/delete support)"
+HOMEPAGE="http://www.rogoyski.com/adam/programs/hexedit/"
+SRC_URI="http://www.rogoyski.com/adam/programs/hexedit/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ncurses-pkg-config.patch
+)
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --program-prefix=curses-
+}
diff --git a/app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch b/app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch
new file mode 100644
index 000000000000..c4fe48bf0224
--- /dev/null
+++ b/app-editors/curses-hexedit/files/curses-hexedit-0.9.7-fno-common.patch
@@ -0,0 +1,53 @@
+--- a/src/hexedit.h
++++ b/src/hexedit.h
+@@ -340,7 +340,7 @@
+
+
+ /* Global structure, keep most global variables here. */
+-struct
++struct Globals_t
+ {
+ WINDOW *wmain, *wstatus, *whelp; /* three windows used throughout. */
+ unsigned long filesize; /* size of the file buffer. */
+@@ -362,7 +362,9 @@
+ /* buf end. */
+ int beeping; /* Allow beeping or not. */
+ int help_msg_count; /* Number of messages in help menu. */
+-} Globals;
++};
++
++extern struct Globals_t Globals;
+
+
+ struct foundit
+@@ -397,7 +399,9 @@
+ int s;
+ struct Change *base;
+ struct Change *top;
+-} UndoStack;
++};
++
++extern struct ChangeLog UndoStack;
+
+
+ struct FileNames
+--- a/src/main.c
++++ b/src/main.c
+@@ -16,6 +16,7 @@
+ #include "hexedit.h"
+ #include <assert.h>
+
++struct Globals_t Globals;
+
+ int
+ main (int argc, char **argv)
+--- a/src/undo.c
++++ b/src/undo.c
+@@ -15,6 +15,7 @@
+ #include <assert.h>
+ #include "hexedit.h"
+
++struct ChangeLog UndoStack;
+
+ void
+ pushUndo (int type, unsigned long offset,