summaryrefslogtreecommitdiff
path: root/app-doc/xmltoman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/xmltoman
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/xmltoman')
-rw-r--r--app-doc/xmltoman/Manifest4
-rw-r--r--app-doc/xmltoman/metadata.xml8
-rw-r--r--app-doc/xmltoman/xmltoman-0.4-r1.ebuild27
-rw-r--r--app-doc/xmltoman/xmltoman-0.4.ebuild23
4 files changed, 62 insertions, 0 deletions
diff --git a/app-doc/xmltoman/Manifest b/app-doc/xmltoman/Manifest
new file mode 100644
index 000000000000..ad06deafa07a
--- /dev/null
+++ b/app-doc/xmltoman/Manifest
@@ -0,0 +1,4 @@
+DIST xmltoman-0.4.tar.gz 15250 BLAKE2B d8641a19742d845fdab0e11703a60c16656c63529a4d86931a8038cbdb87e0fbf241b7ff38ed05ddab62daab608407bd5d7778c060fe3cbef1750976fa588dee SHA512 347722731e2101ecd0619f88f4efdbca534810c96977a1281af685e8a61f4c1a826a71a9f0e3af43cc899936640787366a78077f36d23a9efcfeb789dbcfae22
+EBUILD xmltoman-0.4-r1.ebuild 745 BLAKE2B 54077535fbdf27f2108b320b7a085044b503ceb013b819888ecfd93fdccb499686814c98886b0b58ecff607a2c246aa1109548596fef29240d37b78cb2eb4f2f SHA512 3ee1e6adfda37a6ba790ea5a64f51f0a12b315a65ff58179e6ccec1b6bf422030bcf3a74e419f72bc16c88376add67ff38210939845eecef510d9f0241ff205f
+EBUILD xmltoman-0.4.ebuild 567 BLAKE2B 9142a6e356376250012e8504213ce720ce81458449051983d8661db1f111b24ce2b46a79d4c0f06e25b29c35cbbf4f9161f89b1b19200ff897f80b7d05827082 SHA512 0288c10e81f52a7ab3325480fb761c2244e5317907a160f251ac607fe60b4686545151d5b4e923184fdf69524e5f4a9bc54ff6b5ff5bc571f54281cdf8606819
+MISC metadata.xml 245 BLAKE2B e84a1330aec92254ae747019bf2573a814f3cd529a1bdada2c24e5ea462477b282a32440a839cba164f6f9633830e23c95117920d4593f67a97c0175fafaf25f SHA512 3af134c5e57fc7b4fc055162378739b18f3531620338c3b3475ee94c17817948e44c2fe91c58d544ee29d2fae237e5db80388ae1960b017b7991330603377060
diff --git a/app-doc/xmltoman/metadata.xml b/app-doc/xmltoman/metadata.xml
new file mode 100644
index 000000000000..cb1280aafc9a
--- /dev/null
+++ b/app-doc/xmltoman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">xmltoman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-doc/xmltoman/xmltoman-0.4-r1.ebuild b/app-doc/xmltoman/xmltoman-0.4-r1.ebuild
new file mode 100644
index 000000000000..763b30e35edf
--- /dev/null
+++ b/app-doc/xmltoman/xmltoman-0.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ # 'make install' requires GNU install, upstream is dead and carrying
+ # a patch is more space than redoing it here
+ dobin xmltoman xmlmantohtml
+ insinto /usr/share/xmltoman
+ doins xmltoman.{css,dtd,xsl}
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}
diff --git a/app-doc/xmltoman/xmltoman-0.4.ebuild b/app-doc/xmltoman/xmltoman-0.4.ebuild
new file mode 100644
index 000000000000..28675fb12902
--- /dev/null
+++ b/app-doc/xmltoman/xmltoman-0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/XML-Parser"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}