summaryrefslogtreecommitdiff
path: root/app-doc/pms/pms-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/pms/pms-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/pms/pms-9999.ebuild')
-rw-r--r--app-doc/pms/pms-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-doc/pms/pms-9999.ebuild b/app-doc/pms/pms-9999.ebuild
new file mode 100644
index 000000000000..f3e231a9274f
--- /dev/null
+++ b/app-doc/pms/pms-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git
+ https://anongit.gentoo.org/git/proj/${PN}.git"
+
+DESCRIPTION="Gentoo Package Manager Specification (draft)"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Package_Manager_Specification"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="live"
+IUSE="html twoside"
+
+DEPEND="dev-tex/leaflet
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ || ( dev-texlive/texlive-mathscience dev-texlive/texlive-science )
+ html? (
+ app-text/recode
+ >=dev-tex/tex4ht-20090611_p1038-r5
+ )"
+RDEPEND=""
+
+src_compile() {
+ # just in case; we shouldn't be generating any fonts
+ export VARTEXFONTS="${T}/fonts"
+ emake $(usex twoside TWOSIDE=yes "")
+ use html && emake html
+}
+
+src_install() {
+ dodoc pms.pdf eapi-cheatsheet.pdf
+ if use html; then
+ docinto html
+ dodoc *.html pms.css
+ dosym {..,/usr/share/doc/${PF}/html}/eapi-cheatsheet.pdf
+ fi
+}