summaryrefslogtreecommitdiff
path: root/app-doc/lapack-docs/lapack-docs-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-doc/lapack-docs/lapack-docs-3.1.1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-doc/lapack-docs/lapack-docs-3.1.1.ebuild')
-rw-r--r--app-doc/lapack-docs/lapack-docs-3.1.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-doc/lapack-docs/lapack-docs-3.1.1.ebuild b/app-doc/lapack-docs/lapack-docs-3.1.1.ebuild
index 9d017eec92d0..0789a1733c20 100644
--- a/app-doc/lapack-docs/lapack-docs-3.1.1.ebuild
+++ b/app-doc/lapack-docs/lapack-docs-3.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="Documentation reference and man pages for lapack implementations"
HOMEPAGE="http://www.netlib.org/lapack"
@@ -16,16 +16,16 @@ IUSE=""
S="${WORKDIR}/lapack-${PV}/manpages"
src_install() {
- # These belong to the blas-docs
- rm -f man/manl/{lsame,xerbla}.*
+ # These belong to blas-docs
+ rm -f man/manl/{lsame,xerbla}.* || die
- # rename because doman do not yet understand manl files
- # Not all systems have the rename command, like say FreeBSD
- local f= t=
+ # rename because doman does not yet understand manl files
+ local f t
for f in man/manl/*.l; do
t="${f%%.l}.n"
- mv "${f}" "${t}"
+ mv "${f}" "${t}" || die
done
- doman man/manl/* || die "doman failed"
- dodoc README "${DISTDIR}"/lapackqref.ps || die "dodoc failed"
+
+ doman man/manl/*
+ dodoc README "${DISTDIR}"/lapackqref.ps
}