summaryrefslogtreecommitdiff
path: root/app-doc/halibut/halibut-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/halibut/halibut-1.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/halibut/halibut-1.1.ebuild')
-rw-r--r--app-doc/halibut/halibut-1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-doc/halibut/halibut-1.1.ebuild b/app-doc/halibut/halibut-1.1.ebuild
new file mode 100644
index 000000000000..9b4f6966032f
--- /dev/null
+++ b/app-doc/halibut/halibut-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="yet another free document preparation system"
+HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/halibut/"
+SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ emake -j1 \
+ BUILDDIR="${S}/build" \
+ VERSION="${PV}" \
+ || die "make failed"
+
+ emake -C doc || die "make in doc failed"
+}
+
+src_install() {
+ dobin build/halibut || die
+ doman doc/halibut.1 || die
+ dodoc doc/halibut.txt
+ dohtml doc/*.html
+}