summaryrefslogtreecommitdiff
path: root/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-22.2.9.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-22.2.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
new file mode 100644
index 000000000000..5fd1f6ea0543
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-22.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN}-${PV/./-}
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+# Taken from lispref/ of emacs-22.3
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${MY_P}.tar.bz2"
+
+LICENSE="FDL-1.2+"
+SLOT="22"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-direntry.patch"
+}
+
+src_compile() {
+ makeinfo elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp22.info*
+ dodoc ChangeLog README
+}