summaryrefslogtreecommitdiff
path: root/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-18.1.03.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-18.1.03.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild b/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
index 3e55d5a96b64..8beb5471da6f 100644
--- a/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
+++ b/app-doc/elisp-manual/elisp-manual-18.1.03.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
+S="${WORKDIR}/elisp"
LICENSE="Texinfo-manual"
SLOT="18"
KEYWORDS="amd64 ~ppc x86"
-DEPEND="sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
-S="${WORKDIR}/elisp"
+PATCHES=("${WORKDIR}/patch")
src_prepare() {
+ default
# remove pre-made info files
- rm -f elisp elisp-[0-9]*
- EPATCH_SUFFIX=patch epatch
+ rm -f elisp elisp-[0-9]* || die
}
src_compile() {