summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
commita6266c63b23ed0ee16865627ca53e4f5353f0a5c (patch)
tree6ed71ecc485e9c4903818db305f6ebee454a38db /app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
parent1fd4e372381e1318aae1b7d3338c04156e5da974 (diff)
gentoo auto-resync : 17:07:2022 - 02:30:06
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-99999999.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-99999999.ebuild42
1 files changed, 29 insertions, 13 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
index 2339dc038f41..4bbfc72582a4 100644
--- a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
@@ -1,35 +1,51 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit git-r3
+# Instructions to make a dist tarball:
+# git clone https://github.com/mgorny/eclass-to-manpage && cd eclass-to-manpage
+# make dist ECLASSDIR=~/g/eclass/
DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
-SRC_URI=""
-EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
- https://github.com/gentoo/gentoo.git"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
+ https://github.com/gentoo/gentoo.git"
+ inherit git-r3
+
+ MY_ECLASSDIR="eclass"
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+ # Keep the keywords stable. No need to change to ~arch.
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+ MY_ECLASSDIR="."
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
BDEPEND="sys-apps/gawk
sys-apps/groff"
src_unpack() {
- git-r3_fetch
- git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
-
- git-r3_checkout '' '' '' eclass
- git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_fetch
+ git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
+
+ git-r3_checkout '' '' '' eclass
+ git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
+ else
+ default
+ fi
}
src_compile() {
- emake ECLASSDIR=eclass
+ emake ECLASSDIR=${MY_ECLASSDIR}
}
src_install() {
- emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+ emake install ECLASSDIR=${MY_ECLASSDIR} DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
}