summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-25 14:56:29 +0100
commit22899eb46c1c332d9a8a995c0be0b965fb1bcfc3 (patch)
tree25c77db0aa77917e9d02268c57cdd9fac0d82035 /app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
parentbf2c6ad6782df5963101bc3e73c0d31d65e0829f (diff)
gentoo auto-resync : 25:07:2022 - 14:56:29
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-99999999.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-99999999.ebuild41
1 files changed, 11 insertions, 30 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
index 4bbfc72582a4..d8ff66c9b36b 100644
--- a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
@@ -3,49 +3,30 @@
EAPI=8
-# Instructions to make a dist tarball:
-# git clone https://github.com/mgorny/eclass-to-manpage && cd eclass-to-manpage
-# make dist ECLASSDIR=~/g/eclass/
+inherit git-r3
DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
- https://github.com/gentoo/gentoo.git"
- inherit git-r3
-
- MY_ECLASSDIR="eclass"
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
-
- # Keep the keywords stable. No need to change to ~arch.
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-
- MY_ECLASSDIR="."
-fi
+EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
+ https://github.com/gentoo/gentoo.git"
LICENSE="GPL-2"
SLOT="0"
-BDEPEND="sys-apps/gawk
- sys-apps/groff"
+BDEPEND="sys-apps/gawk"
src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_fetch
- git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
-
- git-r3_checkout '' '' '' eclass
- git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
- else
- default
- fi
+ git-r3_fetch
+ git-r3_fetch "https://github.com/mgorny/eclass-to-manpage.git"
+
+ git-r3_checkout "" "" "" eclass
+ git-r3_checkout "https://github.com/mgorny/eclass-to-manpage.git"
}
src_compile() {
- emake ECLASSDIR=${MY_ECLASSDIR}
+ emake ECLASSDIR=eclass
}
src_install() {
- emake install ECLASSDIR=${MY_ECLASSDIR} DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+ emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
}