summaryrefslogtreecommitdiff
path: root/app-doc/clsync-docs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-doc/clsync-docs
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-doc/clsync-docs')
-rw-r--r--app-doc/clsync-docs/Manifest4
-rw-r--r--app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild39
-rw-r--r--app-doc/clsync-docs/metadata.xml2
3 files changed, 43 insertions, 2 deletions
diff --git a/app-doc/clsync-docs/Manifest b/app-doc/clsync-docs/Manifest
index afdc72deefd6..d52c8d8c643a 100644
--- a/app-doc/clsync-docs/Manifest
+++ b/app-doc/clsync-docs/Manifest
@@ -1,3 +1,5 @@
DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
+DIST clsync-0.4.4.tar.gz 268276 BLAKE2B 0027760cfdee5c4410c4cea45aae2def6498d812d2f50038993c39a33c6029722ec2dd2cfff20815a3ffd8834eb8c439059e5f1d2cc3d2cf98ecb22ed22f2322 SHA512 cdafbf43fdeafe9cb53c08e0514ef356fb5b4bbd8da2226263180e7441d222c76e6c73f847f484b3688a8672e4a85df0346c0236d8d0ed4506d209189af02dcd
EBUILD clsync-docs-0.4.2.ebuild 887 BLAKE2B a4313ec415bf46da96fdc9c74fe23db50d02cda780234ddab9071a8eabf4020c5a9b8a31acb6acbf889fc94dbd57851f9ba54788d8f969280dc58ba868aaab43 SHA512 6694a4bf978d223ccf75219d4b85754b44b95c81cac77efa701d80def33d8c7bc0043f5a875dfde1ccf608a49bf7e57ba93118679ca8f63c1b38d3a72abe73ad
-MISC metadata.xml 569 BLAKE2B affa352674c37363d695f97f53015f89769c91a1e6ddb35d6a7f4a12e161fd266841f1d2bcc630ef0807c8bb936835e7cf50b26dc3630c718364fb8bc027910d SHA512 21485b31c70a686ff1cbb5af951f4ab0a89841878cda664a396561dd683349c857c0485551c77c924677b4542b35b08ff55b11ca3c20176531bf7e4a1b05f60b
+EBUILD clsync-docs-0.4.4-r1.ebuild 848 BLAKE2B 7e9e9d8e6546a85983410bbb3a2d8877c625f7aaf21eadec5993670296495b48e2eab124bb3181530222ade526e507ff386203c54a29424e6f08c97b688ef455 SHA512 751482b5988ca95c19ca58b46afdd78e3db674048af8d8a663550bc1834e1654923c44fd5609af3dba188de019ea85561be7d8f1804f6fac52f2b268985606f9
+MISC metadata.xml 567 BLAKE2B 1e86873b67b4b15004f61a36746c0ad8a4dfa1e35e3653d38e67a47f03a990170a5fba39f5190a570cc5bc202f6a62f441a36e2ed82b6c573cdb41a9d7c409c1 SHA512 9eae6e4bd8f49691b3df2d2dce4c122bd182caaabf284e7802d07571b5b929f438bd4d74961c5dcd598354f05dfdd0e8161186a11c0b52d0a456cd37628d7003
diff --git a/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild b/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..f7465d6bf3bb
--- /dev/null
+++ b/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN%-docs}"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/clsync/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Clsync and libclsync API documentation"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/clsync/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="api +examples"
+
+BDEPEND="api? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ : # doxygen doesn't depend on configuration
+}
+
+src_compile() {
+ if use api; then
+ doxygen .doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
+ if use api; then
+ dodoc -r doc/doxygen/html doc/devel/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/app-doc/clsync-docs/metadata.xml b/app-doc/clsync-docs/metadata.xml
index 7d716daa96cb..a5008881accb 100644
--- a/app-doc/clsync-docs/metadata.xml
+++ b/app-doc/clsync-docs/metadata.xml
@@ -13,6 +13,6 @@
<flag name="api">Install doxygen generated API docs.</flag>
</use>
<upstream>
- <remote-id type="github">xaionaro/clsync</remote-id>
+ <remote-id type="github">clsync/clsync</remote-id>
</upstream>
</pkgmetadata>