summaryrefslogtreecommitdiff
path: root/app-doc/blas-docs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/blas-docs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/blas-docs')
-rw-r--r--app-doc/blas-docs/Manifest5
-rw-r--r--app-doc/blas-docs/blas-docs-3.1.1.ebuild29
-rw-r--r--app-doc/blas-docs/metadata.xml17
3 files changed, 51 insertions, 0 deletions
diff --git a/app-doc/blas-docs/Manifest b/app-doc/blas-docs/Manifest
new file mode 100644
index 000000000000..e64104729a4c
--- /dev/null
+++ b/app-doc/blas-docs/Manifest
@@ -0,0 +1,5 @@
+DIST blas-report.ps 1874460 BLAKE2B 3bbef21663dd4642c74110356b828fc4d84cf1d70afe10ac6d0c7117cb133b0f6005f9787e6a49040247d485f409511c214990b336177380f631c567ef1eb92c SHA512 90346f29fadb6304afd4e1b6c170fc71008f9ffa750d49256feb3d37e9ba646e5120ee6e3cbfa8f10c7916119591b240c72ec747f8135bf6581539365838b044
+DIST blasqr.ps 235163 BLAKE2B cf9d03453690d4b25ba0f77741cec1f57dcfbb1be81ece8a940dc06539526d31f79a56179e7e33e3c0725c7ffc125779d6a2293cc2550dd8628eddac9a0a71e3 SHA512 8795864bd250abc4e7ba396b35277554e7226161133d57206dd4d843d265632d3a4977386412547d620d0091013add0ae156182fa5cac20a2272f1cb17915289
+DIST lapack-man-3.1.1.tgz 1117350 BLAKE2B 3c1dfa55efdc1a2e11315885d853354060d04f3beab701d0dd9574e67ba9b34ec762c23b6275812a6849fbac0141c7a5fa56a86d4a340caeab5c001bc274392e SHA512 3dca890ec618f8c87de137760bd072a8664afc21d9f73e8b04b8bf1e4fd50f0796f11c9327f10ca34e3169fd55bbe8007da044580713428652eaa2c3dc25982a
+EBUILD blas-docs-3.1.1.ebuild 911 BLAKE2B efc8b46d2c8ccbd293b8665f0a5d426daa54cf1b7a8a1fd0ab2bd132a80cef435e4339706acb850c8c8b7b854446a77b670965ed342e0c7dce5d870391df64fd SHA512 c3d5f9fa2625f85f8ebee771a080a71b0c286b869d5944fd291ba8e73e75b3d73bab869f31d3845909c0e555978842bdbc61e3459a669aff16c210cc301487b6
+MISC metadata.xml 714 BLAKE2B 2d6bafd3860626c883522e2c9d246070e427f19ebe7be1841cb8d78d2e681404e2caf5a07a0bb7f82b8992ecc8a86b7dccc01983fcf6d38bd0758581f164c3d6 SHA512 5bd0b57c069e14559e39b6e693df0218d2620a04169bddb5be98af3ae1e963e7c9f0fc325f27113997853c3bed8f2e5018b5c5081d479f0239f204ee14049161
diff --git a/app-doc/blas-docs/blas-docs-3.1.1.ebuild b/app-doc/blas-docs/blas-docs-3.1.1.ebuild
new file mode 100644
index 000000000000..ddfd1ca6c009
--- /dev/null
+++ b/app-doc/blas-docs/blas-docs-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="Documentation reference and man pages for blas implementations"
+HOMEPAGE="http://www.netlib.org/blas"
+SRC_URI="mirror://gentoo/lapack-man-${PV}.tgz
+ http://www.netlib.org/blas/blasqr.ps
+ http://www.netlib.org/blas/blast-forum/blas-report.ps"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/lapack-${PV}/manpages
+
+src_install() {
+ # rename because doman do not yet understand manl files
+ # Not all systems have the rename command, like say FreeBSD
+ local f= t=
+ for f in blas/man/manl/*.l; do
+ t="${f%%.l}.n"
+ mv "${f}" "${t}"
+ done
+ doman blas/man/manl/*.n || die "doman failed"
+ dodoc README "${DISTDIR}"/blas{-report,qr}.ps || die "dodoc failed"
+}
diff --git a/app-doc/blas-docs/metadata.xml b/app-doc/blas-docs/metadata.xml
new file mode 100644
index 000000000000..4bb6d2f417d7
--- /dev/null
+++ b/app-doc/blas-docs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+BLAS (Basic Linear Algebra Subroutines) is a set of efficient routines
+for most of the basic vector and matrix operations. They are widely
+used as the basis for other high quality linear algebra software, for
+example lapack and linpack. This implementation is the Fortran 77
+reference implementation found at netlib.
+This package contains manual pages for the routines, and other
+quick reference in postscript format.
+</longdescription>
+</pkgmetadata>