summaryrefslogtreecommitdiff
path: root/app-doc/autobook/autobook-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-doc/autobook/autobook-1.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-doc/autobook/autobook-1.5.ebuild')
-rw-r--r--app-doc/autobook/autobook-1.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-doc/autobook/autobook-1.5.ebuild b/app-doc/autobook/autobook-1.5.ebuild
new file mode 100644
index 000000000000..4bb20038f97d
--- /dev/null
+++ b/app-doc/autobook/autobook-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="GNU Autoconf, Automake and Libtool"
+HOMEPAGE="https://sourceware.org/autobook/"
+SRC_URI="https://sourceware.org/autobook/${P}.tar.gz
+ examples? (
+ https://sourceware.org/autobook/foonly-2.0.tar.gz
+ https://sourceware.org/autobook/small-2.0.tar.gz
+ https://sourceware.org/autobook/hello-2.0.tar.gz
+ https://sourceware.org/autobook/convenience-2.0.tar.gz
+ )"
+
+LICENSE="OPL"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 m68k ppc s390 sh x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ dohtml * || die
+ if use examples ; then
+ local d
+ for d in {convenience,foonly,hello,small}-2.0 ; do
+ insinto /usr/share/doc/${PF}/${d}
+ doins -r "${WORKDIR}"/${d}/* || die "doins ${d} failed"
+ done
+ fi
+}