summaryrefslogtreecommitdiff
path: root/app-dicts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
commitb392cbf078526e18db5d54ec37f9580be480fd48 (patch)
treef2f8f60717bb0fbe3df7452c2e0b1e0c192341d1 /app-dicts
parentcd40bc9ab405aca4e72f869db79d9d1ff77d8313 (diff)
gentoo auto-resync : 13:08:2022 - 14:24:01
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/Manifest.gzbin95524 -> 95523 bytes
-rw-r--r--app-dicts/myspell-ca/Manifest2
-rw-r--r--app-dicts/myspell-ca/myspell-ca-3.0.7.ebuild44
3 files changed, 46 insertions, 0 deletions
diff --git a/app-dicts/Manifest.gz b/app-dicts/Manifest.gz
index 3a073afcce69..edbcca8eb328 100644
--- a/app-dicts/Manifest.gz
+++ b/app-dicts/Manifest.gz
Binary files differ
diff --git a/app-dicts/myspell-ca/Manifest b/app-dicts/myspell-ca/Manifest
index 6405e09cfc27..d6923011960d 100644
--- a/app-dicts/myspell-ca/Manifest
+++ b/app-dicts/myspell-ca/Manifest
@@ -1,3 +1,5 @@
DIST myspell-ca-3.0.6.oxt 1729644 BLAKE2B d20655f9f3533aa280706463b9db0263e30294e3ca9468dad4f3f9273ff19d91d65c247e7a5ab954d9497f7f1f388129ca596759067c718899575e92110ff778 SHA512 4d5b867bd1a923bb2d52fba4b30d73f9e5b4d441c78c77aa88b0d67cf9d7ebef9cac0f0ea1addbaf873b6395590a1295fc43f7a9a0567af79f351d1dc2618259
+DIST myspell-ca-3.0.7.oxt 4743865 BLAKE2B 019d171f06b8bc5c4e3359213907bdb11f53aaf153899e643d18c0fd2f2c090b05018d0ef32c9f3238730ecad7859423ddb3f7b9081acdda820f29af192c58bc SHA512 75f42a3e1723e75a535f352e72018add4baf0faab4c89208fbd732579f75f040138d9c784fe6e96bbc8194c2416731e920a6950fd9a9a196dbacfd1a03d4512d
EBUILD myspell-ca-3.0.6.ebuild 1109 BLAKE2B ad1ea8bc5ab67b03268d707f0ae07f8ec0b7543d460bcb42d199de585b2b2126c42189db9922e741582e6e7e7d7417c03953bd80f601183a7f2e3ccc7fd94428 SHA512 d0212c0e3cea33000220874b351c6e718eaf9bf3d2fc1a630294c9823d654e2ab5dfc5517a6b9302eeaee4b2908201bc17b1ceef7b51d6e53be3bcfbb65cecd6
+EBUILD myspell-ca-3.0.7.ebuild 1110 BLAKE2B 6289ea6e5307cf0963b7242e4f3759f9ee88ba4d67b03f2e73e6bbc1091c29ca5ee944d7d660cbe15bbbbb3a644b646c373187ca650ad5316c1da8cd685e66b6 SHA512 48607013eff9164ff96f5785f13a808f5216920722f7788afcb13659a3f07185585f578b9f382355c091198f690924741f1ae465040eb3b05c195cae71338d23
MISC metadata.xml 434 BLAKE2B e98e3af7d90546b1c388e24c2d791cdd32f07cde9150c79637d8805780202518a6ca6dfe6fa8e89bd2e6f8ca4b08234c03903644db3705be2d0df5cc36afbd44 SHA512 303e0ef4f85b81518360bfb7d19500a5c11c865e4ac765bc58f13f5aaaf5f5218f634e546740e40492f23256d4dccdecc996a90a6d79856c28ed15b4ee884842
diff --git a/app-dicts/myspell-ca/myspell-ca-3.0.7.ebuild b/app-dicts/myspell-ca/myspell-ca-3.0.7.ebuild
new file mode 100644
index 000000000000..bc4530071db3
--- /dev/null
+++ b/app-dicts/myspell-ca/myspell-ca-3.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYSPELL_DICT=(
+ "ca_ES.aff"
+ "ca_ES.dic"
+ "ca_ES-valencia.aff"
+ "ca_ES-valencia.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_ca_ES.dic"
+)
+
+MYSPELL_THES=(
+ "th_ca_ES.idx"
+ "th_ca_ES.dat"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Catalan dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.softcatala.org/programes/corrector-ortografic-de-catala-general-per-al-libreoffice-i-lapache-openoffice/ https://github.com/Softcatala/catalan-dict-tools/"
+SRC_URI="https://github.com/Softcatala/catalan-dict-tools/releases/download/v${PV}/ca.${PV}.oxt -> ${P}.oxt"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # rename to conform the common naming scheme
+ mv ca.aff ca_ES.aff || die
+ mv ca.dic ca_ES.dic || die
+ mv ca-ES-valencia.aff ca_ES-valencia.aff || die
+ mv ca-ES-valencia.dic ca_ES-valencia.dic || die
+ mv hyph_ca.dic hyph_ca_ES.dic || die
+
+ # remove licenses
+ rm LICENSES-en.txt LLICENCIES-ca.txt || die
+}