summaryrefslogtreecommitdiff
path: root/app-dicts/verbiste
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-dicts/verbiste
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-dicts/verbiste')
-rw-r--r--app-dicts/verbiste/Manifest4
-rw-r--r--app-dicts/verbiste/metadata.xml4
-rw-r--r--app-dicts/verbiste/verbiste-0.1.47.ebuild61
3 files changed, 67 insertions, 2 deletions
diff --git a/app-dicts/verbiste/Manifest b/app-dicts/verbiste/Manifest
index b0f52255cae2..23d02c107639 100644
--- a/app-dicts/verbiste/Manifest
+++ b/app-dicts/verbiste/Manifest
@@ -1,3 +1,5 @@
DIST verbiste-0.1.44.tar.gz 780465 BLAKE2B 692fd3bdf00323b08d4c8a66baaf9f6800c4593428d36efb4cd4bfc51eea912297154e4b0610b94b66d1354317ac7cf24d6dca083d521c648338a0974f6d0899 SHA512 36c8a2af31f948dc3970bef260d5cd7f9d230f4966f846bcc823f006cd98ab98229544b7470466529344ac5735d1189c859c539f526cd58410d9a521510db5e5
+DIST verbiste-0.1.47.tar.gz 781085 BLAKE2B 39f92bffc2165b49a2cd66ced4337aa4eb4253a1d767f0c26cea0bc10e965a5547158ab0de796b76016fd46bd220b305a14c9be42b76f5a25f0fde85e4ff1b97 SHA512 cc06d3e4a09b9edf2fe3996f527ae05fa50af909cc5ea6ed830d1b4f5706cf9b29028160cff842a211148e13d736f7e2cb74f10b3c5fd84d93a1038e05a26cbf
EBUILD verbiste-0.1.44.ebuild 1077 BLAKE2B 471a7b35cbda9b96fc7f9a3ccaffa551dbd2f5d187d40494214530e0527691b8cc581654ed7f6da74a74ce80843a7c220582ff9191f46682c034b1610cbe3c41 SHA512 71854c5a75f47c23b87d229c1849164d3f9b248d4cc78a8786a9656be8726d752f9331f9b03415d9ebe4273cf4d56ab2eea49a660b7354c0775c3039444c0164
-MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
+EBUILD verbiste-0.1.47.ebuild 1080 BLAKE2B 3e5b3799305c00d4546e649bcc54bc5a0ec434b3a5ee7286c63a896c58853cecaf7699c91cdf456551c0ea27b19ac4c3e04953d632ea4f706a465e89533d4937 SHA512 af05c6b2f31d7e808c1737a0577cabb8acf3cb2e6d06a02f9ef104fb917d4562b303efa962803e0cf3eac7d76cdd57b530648666228a3008bf12d4bfd6100a70
+MISC metadata.xml 215 BLAKE2B fcfa022f4341f16a12099b6fc713f8b871a4ddf552c5b471a4aacbaa3b467061525094621f98b83f7167aa495ddac7eef811216df06ae9d2fa14b8bd23902bad SHA512 b467b6c2737837f8eef342a9dcc72151bd7fffd8b37311ec6ef54ef9ece11c23570167625e01860ab9fb90c0de0ead45d4610ac2d96143bc55a4c8febc0906e3
diff --git a/app-dicts/verbiste/metadata.xml b/app-dicts/verbiste/metadata.xml
index 7a38bb900964..38fdd24389ab 100644
--- a/app-dicts/verbiste/metadata.xml
+++ b/app-dicts/verbiste/metadata.xml
@@ -1,5 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>remi@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/app-dicts/verbiste/verbiste-0.1.47.ebuild b/app-dicts/verbiste/verbiste-0.1.47.ebuild
new file mode 100644
index 000000000000..dc372435661b
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.47.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ domenu src/gnome/verbiste.desktop
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}