summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-pl/myspell-pl-20130306.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/myspell-pl/myspell-pl-20130306.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/myspell-pl/myspell-pl-20130306.ebuild')
-rw-r--r--app-dicts/myspell-pl/myspell-pl-20130306.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-dicts/myspell-pl/myspell-pl-20130306.ebuild b/app-dicts/myspell-pl/myspell-pl-20130306.ebuild
new file mode 100644
index 000000000000..126e6d619a33
--- /dev/null
+++ b/app-dicts/myspell-pl/myspell-pl-20130306.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "pl_PL.aff"
+ "pl_PL.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_pl_PL.dic"
+)
+
+MYSPELL_THES=(
+ "th_pl_PL_v2.dat"
+ "th_pl_PL_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Polish dictionaries for myspell/hunspell"
+# dict is bumped every day but nothing changes, RECHECK BEFORE DOING VERSION BUMP!
+# hyphen has no website
+# thesarus released last in 2k8
+HOMEPAGE="
+ http://www.sjp.pl/slownik/en/
+ https://sourceforge.net/projects/synonimy/
+"
+SRC_URI="
+ http://sjp.pl/slownik/ort/sjp-myspell-pl-${PV}.zip
+ http://www.openoffice.org/pl/pliki/hyph_pl_PL.zip -> ${P}-hyph.zip
+ mirror://sourceforge/synonimy/OOo2-Thesaurus-1.5.zip -> ${P}-thes.zip
+"
+LICENSE="CC-SA-1.0 LGPL-3 GPL-3 MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ myspell-r2_src_unpack
+
+ # ZIPCEPTION!
+ unzip hyph_pl_PL.zip
+ unzip pl_PL.zip
+}